Bug 250953 - proxy autoconfigure failing.
proxy autoconfigure failing.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 21:59 EDT by David Woodhouse
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 20:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-08-05 21:59:34 EDT
I use the proxy autoconfigure script at http://david.woodhou.se/proxy.pac.txt to
provide access to company-internal web sites, and to things which are
problematic from within China.

I noticed yesterday that the dnsDomainIs() tests don't seem to be working -- it
always falls through to the 'DIRECT' at the end. I can make things work by
uncommenting the unconditional proxy line (yes, I know that one's a different port).

This used to work fine, until quite recently. I installed firefox-2.0.0.5.1.fc7
on the 18th of July; it's probably been broken since then. I don't think I've
done anything in the last couple of weeks which would cause me to notice the
breakage -- I rarely access company-internal web pages, and I haven't actually
been in China until yesterday, so direct access to the BBC and Wikipedia would
have worked fine.
Comment 1 Christopher Aillon 2007-08-07 13:39:14 EDT
And this code has not changed since 2001, not sure why it's suddenly failing.

function dnsDomainIs(host, domain) {
  return (host.length >= domain.length &&
          host.substring(host.length - domain.length) == domain);
}

I suppose you can try including that function yourself, in the pac file to see
if it helps.  Otherwise, perhaps the breakage is that host is not getting set
properly?  alert() might help debug there.
Comment 2 David Woodhouse 2007-08-07 20:31:32 EDT
Ah, this hotel seems to have started giving DNS results for nonexistent hosts --
so removing the 'isResolvable()' test for redhat-internal makes it work. Sorry
for the noise.

Note You need to log in before you can comment on or make changes to this bug.