Bug 250956 - Compact Flash reader on PS3 does not work
Compact Flash reader on PS3 does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 22:56 EDT by Jason
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.9-91.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 19:07:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2007-08-05 22:56:29 EDT
Description of 
problem:
Fedora 7 fails 
to mount Compact 
Flash Card on PS3

Version-Release 
number of 
selected 
component (if 
applicable):
rpm -q udev
udev-113-8.fc7


How reproducible:
Always

Steps to 
Reproduce:
1.Insert known 
working 
CompactFlash 
card into CF 
Card Reader on 
PS3.
2.Double click 
on Computer 
(Gnome Desktop)
3.Double Click 
on Sony GL819 CF
4.Error Message 
displays, "There 
is probably no 
media in the 
drive."
  
Actual results:
card does not 
mount

Expected results:
card mounts

Additional info:
The kernel is 
spitting out 
this non stop in 
/var/log/
messages:
Aug  5 22:43:55 
PS3vault kernel: 
sd 1:0:0:1: 
[sdc] Sense not 
available.
Aug  5 22:43:55 
PS3vault kernel: 
sd 1:0:0:1: 
[sdc] Write 
Protect is off
Aug  5 22:43:55 
PS3vault kernel: 
sd 1:0:0:1: 
[sdc] Assuming 
drive cache: 
write through
Aug  5 22:43:55 
PS3vault kernel: 
sd 1:0:0:1: 
[sdc] READ 
CAPACITY failed
Aug  5 22:43:55 
PS3vault kernel: 
sd 1:0:0:1: 
[sdc] Result: 
hostbyte=DID_ERROR 
driverbyte=DRIVER_OK,SUGGEST_OK
Comment 1 Harald Hoyer 2007-08-06 05:28:58 EDT
Please try:
# yum --enablerepo=*-testing update udev 
Comment 2 Jason 2007-08-06 07:07:39 EDT
I ran this, however I had already updated to the version in testing (udev-113-
8.fc7), so this only reported: Could not find update match or udev. Is there a 
newer version I should obtain somewhere else?

Also, in fairness, I am only guessing that this is a udev problem, due to the 
recent problems everyone has had mounting disks; I was experiencing the same 
with an external HDD, and all those problems were corrected when I updated to 
this version of udev, however the card reader is still not working.
Comment 3 Harald Hoyer 2007-09-20 06:19:03 EDT
[sdc] READ  CAPACITY failed
[sdc] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK

assigning to kernel
Comment 4 Chuck Ebbert 2007-09-20 18:08:34 EDT
What kernel version is this happening with?
Comment 5 Jason 2007-09-20 22:52:03 EDT
kernel-2.6.22.5-76.fc7 (ppc64)

This has been an extremely intermittent problem on the PS3. With some kernels 
it has worked, others not, and I'm not entirely certain that udev isn't 
completely out of the blame.

I tried with the latest rawhide kernel 2.6.23-0.189.rc6.git8.fc8 and it did not 
do any better.
Comment 6 Bill Blake 2007-10-11 18:48:09 EDT
I am not experiencing this problem on 2.6.22.9-91.fc7.
udev.ppc  113-12.fc7 

I have a used a SanDisk  Cruzer Mini 1 GB USB Flash drive, Ativa 8 GB USB Flash
drive, Kodak 1 GB SD card, Sandisk Extreme III 4 GB CF card, and Sony 1 GB
Memory stick.  All will automount when inserted.

At one point I even had F7 installed using LVM over the 4 GB CF and 1 GB USB
flash drive, but have since installed to the internal hard drive.

Note You need to log in before you can comment on or make changes to this bug.