Bug 25097 - Problem installing Red Hat 7... most likely RAID error
Problem installing Red Hat 7... most likely RAID error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-27 18:05 EST by Shane Little
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 11:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Little 2001-01-27 18:05:51 EST
I'm installing RH7.  Pentium 180, 64MB RAM.  Setting up software raid on 3 
drives. 2 primary IDE, 1.2 gig and 1.0 gig.  1 Secondary IDE, 1.2 gig. 
setup 64MB swap on hda, and 16MB /boot on hda. setup RAID-0 on hda, hdb, 
hdc for a total of something like 3 gig.  Tried several different 
combinations of RAID setup.  I get the exact same error no matter what I 
do after the last screen in the setup process.  Here is the error:

[BEGIN ERROR]
Traceback (inntermost last):
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py",line 
20, in run
  rc = self.todo.doinstall ()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1469,  in 
doinstall
  self.fstab.makeFilesystems ()
 File "fstab.py", line 551, in makFilesystems
  self.createRaidTab("/tmp/raidtab",""/tmp",createDevices = 1)
 File "fstab.py", line 464, in createRaidTab
  isys.makeDevInode(device, devPrefix + '/' + device)
 File "isys.py", line 195, in makeDevInode
  return _isys.mkdevinode(name, fn)
SystemError: (0, 'Error')
[END ERROR]

HELP!
Comment 1 Michael Fulbright 2001-01-29 19:44:00 EST
What are the steps you took in the installer before getting this error?
Comment 2 Shane Little 2001-02-02 12:39:19 EST
Selected Custom system setup.  Selected manually partition with disk druid.  
Set up 1 partition on each hard drive(total of 3).  Set up RAID Device in disk 
druid.  Selected various packages, added up to something like 550 MB.  After 
clicking on 'next' in the final screen of install, before the packages are 
installed, the error appears on the screen.
Comment 3 James Pattie 2001-02-03 18:17:02 EST
I'm getting a similar problem (different error) and have tracked it down to the
fact that when booting off the boot floppy (my computer won't boot off cd) the
raidX modules are not being loaded.  a cpio error is blown.  I was able to get
around it by saying "expert" instead of just hitting enter at syslinux prompt
and then telling it to boot off local cd and not load any special drivers, etc. 
Then the raid modules are properly loaded and available.  I even re-created the
boot image and even loaded the update image you have and nothing worked until I
tried the expert install.

Why doesn't the network installation go into graphical mode, but booting off cd
or local boot floppy will?  Is there any way to create a raid array in the text
installer?
Comment 4 Michael Fulbright 2001-02-06 15:37:16 EST
I will try to duplicate this on a system here.
Comment 5 Michael Fulbright 2001-04-11 12:20:38 EDT
Is it possible you have a bad floppy?  Could you try with a different one?
Comment 6 Brent Fox 2001-05-01 11:15:43 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.