Bug 250978 - Spelling Correction does not properly handle completion when appending 1-character suffixes
Summary: Spelling Correction does not properly handle completion when appending 1-char...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh   
(Show other bugs)
Version: 5.0
Hardware: i386 Linux
low
low
Target Milestone: ---
: ---
Assignee: Fridolín Pokorný
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-06 09:34 UTC by Alan
Modified: 2013-04-12 10:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-12 10:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan 2007-08-06 09:34:26 UTC
Description of problem:

Spelling Correction does not properly handle completion when appending
1-character suffixes

Version-Release number of selected component (if applicable):

tcsh-6.14-12.el5

How reproducible:

always

Steps to Reproduce:
1.  create a command completion that includes a suffix.  I am using:
complete scp          C%./%f% n/./"(host1 host2)"/: p/1/"(host1 host2)"/:

2.  give a command that would fall under the completion rule.  eg:
scp ./tarfile.tar host1:
  
Actual results:

Spelling Correction attempts to correct the last argument in the above command
to the same argument without the appended suffix (in this case the colon) as in:

CORRECT>scp ./tarfile.tar host1 (y|n|e|a)?

Expected results:

Spelling Correction should not intervene here at all

Additional info:

yes, I could just add a colon to the end of each host statement in the list, but
that would mean I couldn't expand variables which is how I'm actually using it
in practice.  

Also, this does not seem to be an issue when the suffix is a trailing / (added
to a directory) as described in the tcsh man page and controlled by the
addsuffix variable.  

fignore does not seem to change this behavior

Comment 3 RHEL Product and Program Management 2011-09-23 00:07:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 Fridolín Pokorný 2013-04-12 10:58:44 UTC
I am not able to reproduce the issue with RHEL-6. I assume it was fixed meanwhile. Feel free to reopen if you have reproducer on current RHEL.

I am sorry, but it is now too late in the RHEL-5 release cycle.
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first
production phase 2 [1] release of RHEL-5. Since phase 2 we'll be
addressing only security and critical issues.

This one issue is fixed in RHEL-6 therefore I am closing the bug as
WONTFIX.

[1] https://access.redhat.com/support/policy/updates/errata/


Note You need to log in before you can comment on or make changes to this bug.