Bug 251035 - libgcj (gcc) has a broken upgrade path from FC6 to F7
libgcj (gcc) has a broken upgrade path from FC6 to F7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 13:30 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.2-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 17:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-08-06 13:30:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
gettext seems to have been built against an unreleased update to libgcj, thus preventing its installation due to unresloved dependency on a newer libgcj than is present in current f7-updates repo.

Version-Release number of selected component (if applicable):
gettext-devel-0.16.1-8.fc7

How reproducible:
Always


Steps to Reproduce:
1. yum install gettext-devel


Actual Results:
$ sudo yum install gettext-devel
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Setting up Install Process
Parsing package install arguments
Loading mirror speeds from cached hostfile
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Running transaction check
---> Package gettext-devel.x86_64 0:0.16.1-8.fc7 set to be updated
--> Processing Dependency: libgettextlib-0.16.1.so()(64bit) for package: gettext-devel
--> Processing Dependency: libgcj.so.8rh()(64bit) for package: gettext-devel
--> Processing Dependency: gettext = 0.16.1-8.fc7 for package: gettext-devel
--> Processing Dependency: libgettextsrc-0.16.1.so()(64bit) for package: gettext-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gettext.x86_64 0:0.16.1-8.fc7 set to be updated
---> Package gettext-devel.x86_64 0:0.16.1-8.fc7 set to be updated
--> Processing Dependency: libgcj.so.8rh()(64bit) for package: gettext-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libgcj.so.8rh()(64bit) is needed by package gettext-devel


Expected Results:
gettext-devel should have been installed without problems.

Additional info:
Comment 1 Dominik 'Rathann' Mierzejewski 2007-08-06 14:52:13 EDT
OK, make that: there is a broken upgrade path from FC6 to F7, i.e. libgcj in F7
is older than in FC6.
Comment 2 Dominik 'Rathann' Mierzejewski 2007-08-06 15:39:32 EDT
To be more precise: (current) fc6 has gcc-4.1.2-13.fc6 (and all the accompanying
packages), while (current) f7 has gcc-4.1.2-12. That's why, when you upgrade,
you get stuck with packages from fc6.
Comment 3 Andrey 2007-08-17 10:24:31 EDT
I am trying to install Eclipse (yum groupinstall Eclipse) to F7. After long list
of dependencies checking is says:

--> Running transaction check
---> Package gcc-java.i386 0:4.1.2-12 set to be updated
---> Package libgcj-devel.i386 0:4.1.2-12 set to be updated
--> Processing Dependency: gcc = 4.1.2-12 for package: gcc-java
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 4.1.2-12 is needed by package gcc-java

Direct yum install libgcj-devel results in transaction check error:

  file /usr/include/c++/4.1.2 from install of libgcj-devel-4.1.2-12 conflicts
with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/ChannelBinding.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/GSSContext.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/GSSCredential.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/GSSException.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/GSSManager.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/GSSName.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/MessageProp.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/include/c++/4.1.2/org/ietf/jgss/Oid.h from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/lib/gcc/i386-redhat-linux/4.1.2 from install of
libgcj-devel-4.1.2-12 conflicts with file from package libstdc++-devel-4.1.2-13.fc6
  file /usr/lib/gcc/i386-redhat-linux/4.1.2 from install of
libgcj-devel-4.1.2-12 conflicts with file from package gcc-4.1.2-13.fc6
  file /usr/lib/gcc/i386-redhat-linux/4.1.2 from install of
libgcj-devel-4.1.2-12 conflicts with file from package gcc-c++-4.1.2-13.fc6
  file /usr/lib/gcc/i386-redhat-linux/4.1.2 from install of
libgcj-devel-4.1.2-12 conflicts with file from package gcc-gfortran-4.1.2-13.fc6

I guess the reason is the same - 4.1.2-12 vs. 4.1.2-13
Comment 4 Dominik 'Rathann' Mierzejewski 2007-08-17 12:47:17 EDT
As a workaround, you can download the relevant f7 packages from the repository
manually and run rpm -Uvh --oldpackage on them.
Comment 5 Skip VerDuin 2007-08-21 19:34:43 EDT
Please allow me to underscore this issue with a little more info:
My FC-7 was an upgrade from FC-6 on 7/4/07, no reported problems were obvious.
I have used pup [Software Update] weekly since that date.
Several things have been "flaky" since upgrade.
Including pup itself that randomly stalls - workaround to restart works OK.

On 8/19 I used "rpm -V -a" and got 20 "Unresolved dependencies...".
More than 1/3 were for libgcj.so.8rh which lead me to this report.
Also "libgcj-src-4.1.2-12.i386" lists its product "libgcj = 4.1.2-12" as a
dependent [?!strange!?].
After pam on 8/21/07 I repeated "rpm -V -a" and got 21 Unresolved (worse).

For me, the 8/17 workaround has not been workable (perhaps lack of experience).
I have not yet located a download source that seems trustworthy.
Yum repo.d leads to duke.edu that leads to a statement "we support [only?] FC-6".

While this issue accounts for 9 of 20, the other 11 are single & double
occurrences of other package dependencies that also remain unsatisfied and the
toolkit of pam/yum/rpm are having tough times dealing with.  See also that:
  libgcj-4.1.2-13.fc6 provides libgcj.so.7rh
  libgcj-4.1.2-12     provides libgcj.so.8rh
which I interpret as a lower package rev provides a higher module rev. similar
to comment #2 above but not identical?
Comment 6 Fedora Update System 2007-08-29 13:27:46 EDT
gcc-4.1.2-18.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-09-28 17:24:43 EDT
gcc-4.1.2-27.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.