Bug 251072 - NetworkManager and ipw suspend/resume flakyness
NetworkManager and ipw suspend/resume flakyness
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 17:35 EDT by Daniel Riek
Modified: 2008-09-29 22:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 22:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2007-08-06 17:35:33 EDT
When suspending/resuming a system with RHEL5, Network manager often does not see
anymore Networks Interfaces after resume. This has been reproduced with ipw2100,
2200 and 3945 based wireless cards in Thinkpad laptops with 5.0 and 5.1 Beta.

It failed in 6 of 10 cases (tested approx. 40 cases).

While it at this point is unclear whether the problem is in NetworkManager or in
the wireless drivers, the fact that it also does not see the ethernet interface
suggests that it is NetworkManager. Restarting NetworkManager IS a workaround
that helped in every case during the test. At least in the caes tested for this,
also deactivating networking in the NetworkManager menue and then re-activating
it helped.

So a short term solution might be to add a NetworkManager restart to the
gnome-powermanagement quirks.
Comment 1 Christopher Aillon 2007-08-07 13:45:53 EDT
So, notting just ran into this issue as well and adding "sleep 2" just before
the dbus-send call fixes this.  Looks like a race...
Comment 2 Dan Williams 2008-03-28 14:10:03 EDT
This should be fixed in 5.2 by a combination of #215720 and #362421.  Can you
test with the version of NM in 5.2 Beta (0.6.4-7.el5) ?
Comment 3 Dan Williams 2008-09-29 22:01:47 EDT
This was fixed in 5.2 and fix will also be present in NM rebase in 5.3.

Note You need to log in before you can comment on or make changes to this bug.