Bug 251090
| Summary: | ds_remove cannot remove/rename directories | ||||||||||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
| Product: | [Retired] 389 | Reporter: | Noriko Hosoi <nhosoi> | ||||||||||||||||
| Component: | Admin | Assignee: | Noriko Hosoi <nhosoi> | ||||||||||||||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Viktor Ashirov <vashirov> | ||||||||||||||||
| Severity: | low | Docs Contact: | |||||||||||||||||
| Priority: | low | ||||||||||||||||||
| Version: | 1.0.4 | CC: | jgalipea | ||||||||||||||||
| Target Milestone: | --- | ||||||||||||||||||
| Target Release: | --- | ||||||||||||||||||
| Hardware: | All | ||||||||||||||||||
| OS: | Linux | ||||||||||||||||||
| Whiteboard: | |||||||||||||||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||||||||||||||
| Doc Text: | Story Points: | --- | |||||||||||||||||
| Clone Of: | Environment: | ||||||||||||||||||
| Last Closed: | 2015-12-07 16:41:10 UTC | Type: | --- | ||||||||||||||||
| Regression: | --- | Mount Type: | --- | ||||||||||||||||
| Documentation: | --- | CRM: | |||||||||||||||||
| Verified Versions: | Category: | --- | |||||||||||||||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||||||||||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||||||||||||
| Embargoed: | |||||||||||||||||||
| Bug Depends On: | |||||||||||||||||||
| Bug Blocks: | 240316, 427409 | ||||||||||||||||||
| Attachments: |
|
||||||||||||||||||
|
Description
Noriko Hosoi
2007-08-07 01:21:01 UTC
Created attachment 160789 [details]
email discussion with Rich
Created attachment 160834 [details]
cvs diff DSCreate.pm.in
Files: ldapserver/ldap/admin/src/scripts/DSCreate.pm.in
Changes: when creating inst_dir and config_dir, make sure the parent dirs
(lib/<brand>-ds and etc/<brand>-ds) have the specified gid.
Created attachment 160835 [details]
cvs diff (adminserver)
Files:
adminserver/admserv/cgi-src40/ds_remove.in
newinst/src/AdminUtil.pm.in
newinst/src/register-ds-admin.pl.in
Description:
ds_remove.in: fixing a syntax error
AdminUtil.pm.in: return an error when connection fails
register-ds-admin.pl: fixing the error checking
How bo verify the bug: A. creating server instances # become root and run the setup scripts as follows # choose nobody, nobody for the UNIX user and group 1. sbin/setup-ds-admin.pl # create a config server 2. sbin/setup-ds-admin.pl # create a sub server sub1 3. startconsole # create a sub server sub2 4. sbin/setup-ds.pl; sbin/register-ds-admin.pl # create a sub server sub3 B. removing server instances Console: remove a sub server (sub3) Expected result: # du -a | egrep sub3 20 ./etc/fedora-ds/slapd-sub3.removed/key3.db 20 ./etc/fedora-ds/slapd-sub3.removed/secmod.db 72 ./etc/fedora-ds/slapd-sub3.removed/cert8.db 120 ./etc/fedora-ds/slapd-sub3.removed Command line: sbin/ds_removal -s sub2 -w <admin_password> Expected result: # du -a | egrep sub2 20 ./etc/fedora-ds/slapd-sub2.removed/key3.db 20 ./etc/fedora-ds/slapd-sub2.removed/secmod.db 72 ./etc/fedora-ds/slapd-sub2.removed/cert8.db 120 ./etc/fedora-ds/slapd-sub2.removed Created attachment 160872 [details] cvs commit message (comment #2, #3) Reviewed by Rich and Nathan (Thank you!!!) Checked in into HEAD. Created attachment 208571 [details]
Problem description
Created attachment 208641 [details]
cvs diffs
Files:
adminserver: admserv/cfgstuff/admserv.conf.in
admserv/schema/ldif/10dsdata.ldif.tmpl
mod_restartd: mod_restartd/mod_restartd.c
Changes:
1) let ds_remove (CGI) run with the root permission.
2) acl names for SIE group were identical for all the DS instances: "SIE
Group", which should be different for each instance.
Created attachment 208681 [details]
cvs commit message
Reviewed by Rich (Thank you!)
Checked in into HEAD.
Verified. Pass Test machine: cypher.dsdev.sjc.redhat.com (REHL5 64bit) Please refer to bug: 247215 for test steps |