Bug 251124 - can't build rdisc - OPEN_MAX undeclared
Summary: can't build rdisc - OPEN_MAX undeclared
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iputils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 251408 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-07 09:58 UTC by Martin Bacovsky
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 10:54:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Bacovsky 2007-08-07 09:58:21 UTC
Description of problem:
Since OPEN_MAX can be modified during runtime, its definition was removed from libc.


How reproducible:
always

Steps to Reproduce:
1. try to compile in fc8
2.
3.
  
Actual results:
rdisc.c: In function 'do_fork':
rdisc.c:250: error: 'OPEN_MAX' undeclared (first use in this function)
rdisc.c:250: error: (Each undeclared identifier is reported only once
rdisc.c:250: error: for each function it appears in.)
make: *** [rdisc] Error 1

Expected results:
smooth compilation

Additional info:

Comment 1 Martin Bacovsky 2007-08-07 10:54:17 UTC
This issue should be fixed in RAWHIDE (iputils-20070202-4.fc8)

Comment 2 Martin Bacovsky 2007-08-09 08:25:57 UTC
*** Bug 251408 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.