Bug 251127 - udf: support files larger than 1G
udf: support files larger than 1G
Status: CLOSED DUPLICATE of bug 221282
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Martin Jenner
:
: 251239 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 06:08 EDT by Sebastian Marten
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 13:42:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Marten 2007-08-07 06:08:32 EDT
Description of problem:

On RHEL 4 I've done my backup on DVD-RAM formated with the UDF-Filesystem. 
On RHEL 5 I can't write files with more than 1 GB on the Disk.

Today i found that this is a problem from Kernel 2.6.8 to 2.6.22
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=00a2b0f6dd2372842df73de72d51621b539fea44

Is it possible to make a backport of the patch:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=31170b6ad4ebe6c43c1cc3b8112274cf59474de0
Comment 1 Eric Sandeen 2007-08-16 10:01:11 EDT
There are actually more patches than that to make udf safe > 1G, but yes, these
should be backported to RHEL5.  I do have that patchset backported to RHEL5
already, and in fact I filed a bug on this as well, on the same day as you did.
 :)  So I'll dup that bug to this one...

Thanks,

-Eric
Comment 2 Eric Sandeen 2007-08-16 10:01:33 EDT
*** Bug 251239 has been marked as a duplicate of this bug. ***
Comment 3 Eric Sandeen 2007-09-18 13:42:29 EDT
Duping this to Bugzilla Bug 221282: iomega rev 35 - udf - max 1 gb filesize, as
it was filed first.

*** This bug has been marked as a duplicate of 221282 ***

Note You need to log in before you can comment on or make changes to this bug.