Bug 251153 - [RHEL4.6] diskdump fails on MPT/Fusion adapter
Summary: [RHEL4.6] diskdump fails on MPT/Fusion adapter
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Linda Wang
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-07 14:54 UTC by Linda Wang
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:31:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diskdump-mptfusion-fix.patch (672 bytes, patch)
2007-08-07 14:54 UTC, Nobuhiro Tachino
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Nobuhiro Tachino 2007-08-07 14:54:48 UTC
Description of problem:

Diskdump fails on MPT/Fusion since RHEL4-U6-re20070804.0

Version-Release number of selected component (if applicable):

2.6.9-56.EL

How reproducible:

Always.

Steps to Reproduce:
1. Create a diskdump partition on SCSI disk that is connected via MPT/Fusion.
2. Enable diskdump service.
3. Cause panic.
  
Actual results:

Diskdump hangs to wait the completion of host reset.

Expected results:

Diskdump succeeds.

Additional info:

I think this is a regression caused by the update of of MPT/Fusion driver.
The driver on RHEL4U6 does not have some code of diskdump, which existed
on RHEL4U5. The appended patch restores the code. I tested the patch and
confirmed it fixes the problem.

Comment 1 Nobuhiro Tachino 2007-08-07 14:54:48 UTC
Created attachment 160815 [details]
diskdump-mptfusion-fix.patch

Comment 3 RHEL Product and Program Management 2007-08-27 18:15:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Jason Baron 2007-08-29 18:24:15 UTC
committed in stream U6 build 57. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/


Comment 6 Red Hat Bugzilla 2007-10-19 04:06:50 UTC
User ntachino@redhat.com's account has been closed

Comment 7 Red Hat Bugzilla 2007-10-19 04:06:57 UTC
User ntachino@redhat.com's account has been closed

Comment 9 errata-xmlrpc 2007-11-15 16:31:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.