Bug 251193 - kernel caused callback when run in qemu and kqemu is on
kernel caused callback when run in qemu and kqemu is on
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 14:13 EDT by Michal Nowak
Modified: 2013-03-07 21:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 10:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Captured Qemu screen (13.07 KB, image/png)
2007-08-15 10:38 EDT, Michal Nowak
no flags Details
Captured Qemu screen (13.28 KB, image/png)
2007-08-15 10:38 EDT, Michal Nowak
no flags Details
Captured Qemu screen (13.72 KB, image/png)
2007-08-15 10:38 EDT, Michal Nowak
no flags Details
Captured Qemu screen (13.85 KB, image/png)
2007-08-15 10:39 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2007-08-07 14:13:44 EDT
Description of problem:
Fedora kernel causes traceback when run in Qemu with kqemu. Following line was used:

qemu -cdrom Fedora-8-Test-1-Live-i686.iso -m 512 -net nic,model=rtl8139 -net
user -soundhw sb16 -kernel-kqemu

Version-Release number of selected component (if applicable):
qemu-0.9.0
kqemu-1.3.0_pre11

How reproducible:
Run Fedora Test1 ISO image in Qemu, kqemu turned on.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
traceback

Expected results:
no traceback :)

Additional info:
Boot menu -> Uncompressing Linux ... -> Lock dependency validator -> SELinux
initializing -> Checking 'hlt' instruction... OK -> invalid opcode: 0000 [#1] ->
SMP -> Module linked in: -> CPU: 0 (Traceback follows) -> ... -> Kernel panic ...
Comment 1 Chuck Ebbert 2007-08-07 14:37:44 EDT
So, where is the message it printed?
Comment 2 Michal Nowak 2007-08-08 02:03:36 EDT
I guess, I don't get what you think. The message is printed in Qemu's window,
hard to get it from it. If you know how to get the information to stdout (i.e.
console window) via builtin "seriali line", write me how.
Comment 3 Dave Jones 2007-08-14 16:13:32 EDT
even a jpeg screen capture of the window would be better than nothing.
Comment 4 Michal Nowak 2007-08-15 10:38:02 EDT
Created attachment 161362 [details]
Captured Qemu screen
Comment 5 Michal Nowak 2007-08-15 10:38:26 EDT
Created attachment 161363 [details]
Captured Qemu screen
Comment 6 Michal Nowak 2007-08-15 10:38:50 EDT
Created attachment 161364 [details]
Captured Qemu screen
Comment 7 Michal Nowak 2007-08-15 10:39:01 EDT
Created attachment 161365 [details]
Captured Qemu screen
Comment 8 Michal Nowak 2007-08-15 10:40:27 EDT
Attached four shots of Qemu's screen.
Comment 9 Chuck Ebbert 2007-08-15 10:52:55 EDT
This looks like a bug in kqemu -- it is not supporting the clflush instruction.
Nothing we can do about that.

  3b:   0f ae 38                clflush (%eax)  <==  oops here
  3e:   58                      pop    %eax
  3f:   5a                      pop    %edx
  40:   5b                      pop    %ebx

Note You need to log in before you can comment on or make changes to this bug.