Bug 251211 - CUPS version 1.2.12-2.fc7 will not give you the option to print to a parallel printer.
CUPS version 1.2.12-2.fc7 will not give you the option to print to a parallel...
Status: CLOSED DUPLICATE of bug 251272
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 15:44 EDT by Gilbert Sebenste
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 04:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gilbert Sebenste 2007-08-07 15:44:47 EDT
Description of problem: Latest CUPS version breaks parallel printing. No 
printing is possible through a printer on a parallel port.


Version-Release number of selected component (if applicable): 
cups-1.2.12-2.fc7

How reproducible: always


Steps to Reproduce: Using either system-config-printer or http://localhost:631 
to access the CUPS interface directly, I cannot get anything to print to my HP 
Laserjet 4000N. This is because the new version, for whatever reason, doesn't 
accept parallel printers. This problem has just shown up in the latest version. 
Installed with an "yum -y update". I do not know what the previous version of 
CUPS was.

  
Actual results: Files go into the printer queue; printer appears to be dead and 
it does nothing.


Expected results: Printer should start printing.


Additional info:
Comment 1 Gilbert Sebenste 2007-08-07 15:54:31 EDT
Using http://localhost:631, I also get the following error message on screen
after attempting to start the printer:

/usr/lib/cups/backend/parallel failed
Comment 2 Gilbert Sebenste 2007-08-07 15:57:20 EDT
Also, when the error message comes up, the printer state is:

Make and Model: HP LaserJet Series Postscript (recommended)
State: stopped, accepting jobs, published.
Device URI: parallel:/dev/lp0
Comment 3 Gilbert Sebenste 2007-08-08 01:29:46 EDT
We now the problem, per the fedora-users list, and I can't believe I didn't
see it. There's no parallel printer option! The previous CUPS version worked
and rolling back to it fixes the problem. Can this be done, please?
Comment 4 Tim 2007-08-08 02:12:00 EDT
Yesterday printing worked, today it did not.  Looking at my yum.log (tail of it 
below), udev was the only possible culprit.  The last update was a few days 
ago, and I had no problems then.

Aug 04 00:38:18 Installed: audacious.i386 1.3.2-1.fc7
Aug 04 00:38:19 Installed: audacious-plugins-nonfree-mp3.i386 1.3.5-1.lvn7
Aug 08 00:15:46 Updated: openssl.i686 0.9.8b-14.fc7
Aug 08 00:15:55 Updated: libpurple.i386 2.1.0-1.fc7
Aug 08 00:15:56 Updated: libvolume_id.i386 113-8.fc7
Aug 08 00:16:02 Updated: spamassassin.i386 3.2.2-2.fc7
Aug 08 00:16:03 Installed: gnome-python2-gnomekeyring.i386 2.18.0-1.fc7
Aug 08 00:16:03 Updated: libpcap.i386 14:0.9.7-1.fc7
Aug 08 00:16:05 Updated: udev.i386 113-8.fc7
Aug 08 00:16:25 Updated: gnome-applet-music.i386 2.2.0-1.fc7
Aug 08 00:16:51 Updated: pidgin.i386 2.1.0-1.fc7
Aug 08 00:17:12 Updated: epiphany-extensions.i386 2.18.3-3

Reverting to an older version of udev solved this problem for me.

udev-106-4.1.fc7.i386.rpm  (my older cached RPM file)
udev-113-8.fc7.i386.rpm  (my latest update, from yesterday)

rpm -Uvh --oldpackage udev-106-4.1.fc7.i386.rpm

That, plus a reboot, was the only thing I did to get parallel port printing 
working again, for me.  The reboot probably wasn't necessary, but I couldn't 
remember how to restart udev.  The downgrade, alone, wasn't enough.

Now, I can also add a new parallel port printer, via the CUPS HTTP interface.  
Today, before I diddled with udev, the LPT option wasn't on this list.

I think this bugzilla needs redirecting towards the udev package.
Comment 5 Tim Waugh 2007-08-08 04:47:33 EDT

*** This bug has been marked as a duplicate of 251272 ***

Note You need to log in before you can comment on or make changes to this bug.