This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 251212 - CUPS version 1.2.12-2.fc7 will not print to a parallel printer.
CUPS version 1.2.12-2.fc7 will not print to a parallel printer.
Status: CLOSED DUPLICATE of bug 251272
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 15:45 EDT by Gilbert Sebenste
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 04:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gilbert Sebenste 2007-08-07 15:45:57 EDT
Description of problem: Latest CUPS version breaks parallel printing. No 
printing is possible through a printer on a parallel port.


Version-Release number of selected component (if applicable): 
cups-1.2.12-2.fc7

How reproducible: always


Steps to Reproduce: Using either system-config-printer or http://localhost:631 
to access the CUPS interface directly, I cannot get anything to print to my HP 
Laserjet 4000N. This is because the new version, for whatever reason, doesn't 
accept parallel printers. This problem has just shown up in the latest version. 
Installed with an "yum -y update". I do not know what the previous version of 
CUPS was.

  
Actual results: Files go into the printer queue; printer appears to be dead and 
it does nothing.


Expected results: Printer should start printing.


Additional info:
Comment 1 Tom Horsley 2007-08-07 22:09:54 EDT
Me too. I see there was a udev update about the same time as the cups update
and I also see there is no longer a /dev/lp0 device (which is what my printer
URL points at), so perhaps this is udev, not cups, but whatever it is, parallel
port printing has certainly been hosed by recent updates. I currently have:

cups-1.2.12-1.fc7
udev-113-8.fc7

(No, my hardware didn't happen to break at the same time - if I boot windows
it can print just fine on the same hardware).
Comment 2 Tom Horsley 2007-08-07 22:43:23 EDT
When the printer was working, I'd see this in /var/log/messages:

Jul 29 18:32:40 zooty kernel: parport_pc 00:09: reported by Plug and Play ACPI
Jul 29 18:32:40 zooty kernel: parport0: PC-style at 0x378 (0x778), irq 7
[PCSPP,TRISTATE]
Jul 29 18:32:40 zooty kernel: parport0: Printer, Hewlett-Packard HP LaserJet 6L
...
Jul 29 18:32:40 zooty kernel: firewire_core: created new fw device fw0 (0 config
rom retries)
Jul 29 18:32:40 zooty kernel: loop: module loaded
Jul 29 18:32:40 zooty kernel: lp0: using parport0 (interrupt-driven).
Jul 29 18:32:40 zooty kernel: lp0: console ready
Jul 29 18:32:40 zooty kernel: No dock devices found.

Now that the printer isn't working, I see this:

Aug  7 21:55:58 zooty kernel: parport_pc 00:09: reported by Plug and Play ACPI
Aug  7 21:55:58 zooty kernel: parport0: PC-style at 0x378 (0x778), irq 7
[PCSPP,TRISTATE]
Aug  7 21:55:58 zooty kernel: parport0: Printer, Hewlett-Packard HP LaserJet 6L
...
Aug  7 21:55:58 zooty kernel: firewire_core: created new fw device fw0 (0 config
rom retries)
Aug  7 21:55:58 zooty kernel: No dock devices found.

Just sort of zips right past without mentioning /dev/lp0 anymore.
Comment 3 Tim Waugh 2007-08-08 04:45:46 EDT
(In reply to comment #1)
> and I also see there is no longer a /dev/lp0 device (which is what my printer
> URL points at), so perhaps this is udev

Definitely a udev problem.  I'm marking this as a duplicate of bug #251272 --
please try to provide the information Harald has asked for in that bug report.

*** This bug has been marked as a duplicate of 251272 ***

Note You need to log in before you can comment on or make changes to this bug.