Bug 251223 - gnome-sudoku not saving high scores, generated puzzles, state of current game
gnome-sudoku not saving high scores, generated puzzles, state of current game
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 16:29 EDT by Catalin Francu
Modified: 2008-06-02 14:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 14:07:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Contents of ~/.gconf/apps/gnome-sudoku/%gconf.xml (2.36 KB, text/xml)
2007-08-07 16:29 EDT, Catalin Francu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 462754 None None None Never

  None (edit)
Description Catalin Francu 2007-08-07 16:29:28 EDT
Description of problem:

gnome-sudoku not saving high scores, generated puzzles, state of current game

Version-Release number of selected component (if applicable):

gnome-games-2.18.2.1-2.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Open gnome-sudoku.
2. Click File->Generate new puzzles.
3. Select "Generate until reaching target", set "Target number" to 2, select
only very hard puzzles and click "Generate".
4. Wait for generator to complete. My gnome-sudoku came with 3 very hard games,
so now the text correctly updates to say "Very Hard: 5 puzzles".
5. Click Close to dismiss the generator.
6. In the current puzzle, fill in some boxes at random.
7. (Optional, takes some time). Finish an entire game to generate a high score
entry. Type in your name.
8. Exit gnome-sudoku
9. Open gnome-sudoku

Actual results:

a) The current game was not saved. Instead I see the same game started from scratch.
b) The high score table is empty. Game->High scores is grayed out. When I
complete another game, the high score table becomes accessible again and the
previous entry is gone.
c) When I select File->Generate new puzzles, I only see 3 very hard puzzles. The
two that I generated before were not saved.



Expected results:
a) The current state of the game should be saved. The manual (hit F1) section
3.1 even refers to a menu option "File->Resume old game", which does not exist.
b) The high score table should contain entries from previous instances of the game.
c) The generated puzzles should be saved and should be visible under File->New
-> Details.



Additional info:
- I wasn't aware of the gnome-sudoku package in previous Fedora Cores. The first
time I ran the game was in FC7 where it is bundled in gnome-games. Thus, I do
not know if this behaviour existed before.
- I don't know where gnome-sudoku is supposed to save its data. I ran "find
~|grep -i sudoku" and the only result was ~/.gconf/apps/gnome-sudoku/%gconf.xml.
I am attaching that file.
Comment 1 Catalin Francu 2007-08-07 16:29:28 EDT
Created attachment 160851 [details]
Contents of ~/.gconf/apps/gnome-sudoku/%gconf.xml
Comment 2 Ray Strode [halfline] 2007-08-14 11:54:14 EDT
It seems to have:
DATA_DIR = ~/.gnome2/gnome-sudoku/
save_to_dir=os.path.join(DATA_DIR,'games/')
game_loc = os.path.join(save_to_dir,
                        "game%s"%game_number)
saver.pickle_game(self, game_loc)

So it seems like it's supposed to be saving games in ~/.gnome2/gnome-sudoku

Comment 3 Catalin Francu 2007-08-14 13:28:07 EDT
Interesting. ~/.gnome2 exists in the user's account, but ~/.gnome2/gnome-sudoku
does not. I ran gnome-sudoku from the command line to see what it does and it
prints all sorts of errors:

[daria@voronet ~]$ gnome-sudoku 
Unable to load puzzles: <type 'exceptions.IOError'>: [Errno 2] No such file or
directory: '/home/daria/.gnome2/gnome-sudoku/generated_puzzles'
[daria@voronet ~]$ mkdir ~/.gnome2/gnome-sudoku
[daria@voronet ~]$ gnome-sudoku 
Unable to load puzzles: <type 'exceptions.IOError'>: [Errno 2] No such file or
directory: '/home/daria/.gnome2/gnome-sudoku/generated_puzzles'
[daria@voronet ~]$ mkdir .gnome2/gnome-sudoku/games
[daria@voronet ~]$ touch .gnome2/gnome-sudoku/generated_puzzles
[daria@voronet ~]$ gnome-sudoku 
Unable to load puzzles: <type 'exceptions.EOFError'>: 

Gnome-sudoku itself does not seem to create the files if they are not already
there. gnome-sudoku -v prints a bunch of extra information, but it isn't relevant.

Also, it's strange that the "Resume old game" option is missing from the File
menu altogether.


Comment 4 Ray Strode [halfline] 2007-08-14 13:48:38 EDT
Now that you have the directories made, can you still reproduce the problem?
Comment 5 Catalin Francu 2007-08-14 20:17:45 EDT
Yes, the problem is still there. If I only create the directories, gnome-sudoku
still complains about a missing files:

[daria@voronet ~]$ gnome-sudoku
Unable to load puzzles: <type 'exceptions.IOError'>: [Errno 2] No such file or
directory: '/home/daria/.gnome2/gnome-sudoku/generated_puzzles'

If in addition I also create an empty file generated_puzzles, gnome-sudoku
complains about (probably) a bad file format:

[daria@voronet ~]$ touch .gnome2/gnome-sudoku/generated_puzzles
[daria@voronet ~]$ gnome-sudoku
Unable to load puzzles: <type 'exceptions.EOFError'>: 

Then if I generate some puzzles and exit gnome-sudoku, the file
generated_puzzles still has zero length.

The menu option "File->Resume old game", which the manual section 3.1 document,
is absent altogether, regardless of what I do.
Comment 6 Glenn Rottingen 2007-09-23 13:14:13 EDT
I am running F8Test2 with Gnome-Games 2.20.0.1-1.F8 and the same problem is
reoccuring.
Comment 7 Ian Weller 2008-02-29 21:47:48 EST
Problem still exists, gnome-games-2.20.3-1.fc8

I'm currently taking a look to see if it's a problem with upstream or us.
Comment 8 Bug Zapper 2008-05-14 09:54:41 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Kevin R. Page 2008-05-14 10:50:51 EDT
As already stated in comment #7 the problem still exists in the current F8
update. Please could maintainer or reporter change version to 8.

Adding an upstream bz reference - looks like it *might* be fixed in Gnome 2.22 /
F9 (not verified).
Comment 10 Ian Weller 2008-05-14 14:47:58 EDT
changed version to 8. i'll see what it does in F9.
Comment 11 Kevin R. Page 2008-05-19 07:49:11 EDT
Looks good in F9 to me.
Comment 12 Peter van Egdom 2008-06-02 14:07:44 EDT
Thank you for the bug report. Closing bug as per comment #11.

If you still experience this problem after updating to our latest Fedora
release, reopen this bug against that version if this bug exists there.

Note You need to log in before you can comment on or make changes to this bug.