Bug 251230 - Stardict icon does not have transparent background
Summary: Stardict icon does not have transparent background
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: stardict   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Hu Zheng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-07 20:55 UTC by Andrew Zabolotny
Modified: 2010-07-09 11:19 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 06:32:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot of tray notification area with non-default panel background. (17.19 KB, image/png)
2007-08-07 20:55 UTC, Andrew Zabolotny
no flags Details

Description Andrew Zabolotny 2007-08-07 20:55:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Set GNOME panel background to anything but default grey
2. Run stardict and some other tools that create icons in tray notification area
(gxneur, psi, power manager, sylpheed etc).
  
Actual results:
All icons integrate cleanly with non-default background except stardict who
still has the default grey background.

Expected results:
Stardict behaves just like any other program that creates icons in tray
notification area.

Additional info:
See the attached screenshot.

Comment 1 Andrew Zabolotny 2007-08-07 20:55:16 UTC
Created attachment 160859 [details]
A screenshot of tray notification area with non-default panel background.

Comment 2 Hu Zheng 2007-08-08 03:40:47 UTC
This is because StarDict's tray icon is a event box, but not a transparent image
widget, the reason of use event box is to receive middle button key.
To solve the problem, we can move to use gtktrayicon widget, but it don't
support middle button presently. So this bug can't be fixed until the new
feature is implemented by gtk. I have ready reported this feature request ago.
Need waiting.

Comment 3 Hu Zheng 2008-02-21 06:32:45 UTC
Fixed in svn now. Thank you!

Comment 4 Andrew Zabolotny 2010-07-09 11:19:05 UTC
Two years have passed, stardict icon still use the non-transparent background.

Are there any unsolvable problems when using transparent images? Perhaps it's a API limitation in gnome-panel itself?


Note You need to log in before you can comment on or make changes to this bug.