Bug 2513 - libc5 can't find timezone files
Summary: libc5 can't find timezone files
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-03 18:29 UTC by hargrove
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-05 12:48:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hargrove 1999-05-03 18:29:42 UTC
Programs running with libc5 look for their timezone files in
/usr/lib/zoneinfo, but the files are now in
/usr/share/zoneinfo.  So, a symlink is needed.
Also when the TZ environment variable is not set the local
timezone is expected in /usr/lib/zoneinfo/localtime rather
than the current location of /etc/localtime.  Again a
symlink solves the problem.
I think both symlinks should be part of the libc5 package
since they are needed for the proper function of some
libc5-using programs.

Comment 1 Jeff Johnson 1999-05-05 12:48:59 UTC
We cannot add a symlink to replace a directory in rpm because of
the way in which rpm performs an upgrade: the new package (with
the symlink) is installed before the old package (with the directory)
is removed. That means that either the symlink can't be created
because the directory exists during the install or the symlink
is created in the directory that is then removed.

The work around is to create the symlinks manually.


Note You need to log in before you can comment on or make changes to this bug.