Bug 25130 - received this after installing - can't get past it - help!
Summary: received this after installing - can't get past it - help!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-28 12:50 UTC by koogie
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 16:21:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description koogie 2001-01-28 12:50:54 UTC
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1631, in 
doInstall
    self.fstab.write (self.instPath)
  File "fstab.py", line 742, in write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage/dev/hda'

Local variables in innermost frame:
which: 5
dir: /mnt/sysimage/dev/hda
elements: ['', 'mnt', 'sysimage', 'dev', 'hda']
path: /mnt/sysimage/dev/hda

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-01-30 00:40:34 UTC
Please give step by step instructions on how to reproduce this issue.

Comment 2 koogie 2001-01-30 21:12:10 UTC
I'm running Windows 98 on my pc already.  I partitioned my harddrive with fips,
formatted the new partition, then rebooted to begin installing redhat 7.  This
took me through partitioning with DiskDruid, then formatting these partitions. I
then selected the custom install and chose the packages I wished.  Everything
seemed to go smoothly, until at the very end, after all of the packages had
installed, I was advised that an exceptional error had occured, and that I
should copy the text of the error and file a bug report here.  The text of the
error was as above.  I have since tried to install redhat again (both custom and
workstation install)  and have each time got to the same stage before this error
has again occurred.  I would appreciate any help you could give me- I'm totally
new to unix, therefore I would be grateful if you could keep it simple

Comment 3 Michael Fulbright 2001-02-01 19:54:21 UTC
Did you ever go back/forwards or just forwards through each screen?

I have not been able to reproduce this behavior just going straight through the
screens.


Comment 4 koogie 2001-02-02 19:55:59 UTC
Thanks, I tried yet again, this time making certain to only go forwards, and 
it's now installed successfully.  Thanks again.

Comment 5 Michael Fulbright 2001-02-08 18:15:07 UTC
I'm glad it worked, but I'd really like to know how to reproduce your original
problem so I can fix it :)

Could you remember the sequence of the screens you went back/forwards through,
and the values you entered?

Comment 6 koogie 2001-02-13 17:39:19 UTC
Hi, as far as I remember (it was a couple of weeks ago now), I chose to
partition my disk with Disk Druid, went on to the next screen where I set the
partition sizes: / = 250 MB, /usr = 2 GB, /swap = 128 MB, var = 125 MB, opt =
approx 300 MB.  I then went back to the previous screen to check something
(can't remember what) and then went forward again.  As far as I can remember
this is the only time I went backwards through the screens - I hope it helps!

Comment 7 Michael Fulbright 2001-02-15 17:18:42 UTC
Thanks - I think this is a know problem.


Note You need to log in before you can comment on or make changes to this bug.