Bug 251318 - bad size parsing in part
Summary: bad size parsing in part
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pykickstart   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-08 11:19 UTC by Levente Farkas
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 17:27:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Levente Farkas 2007-08-08 11:19:06 UTC
Description of problem:
while this line cause an error "requires size specification"
part / --fstype ext3 --onbiosdisk --size=1 --grow
this line runs without problem:
part / --fstype ext3 --ondisk=sda --size=1 --grow
imho it's a bug!
on the other hand if in part you can include --onbiosdisk it'd be very useful
(since imho otherwise it's unusable) to include --onbiosdisk in clearpart too.
currently there is no way to clear all partition on the bios disk and create
partition on it.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2007-08-09 17:27:22 UTC
What's going on here is that --onbiosdisk requires an argument to tell it which
BIOS disk to put the partition on (something like 0x80, ... I believe). 
However, our option parsing does not handle the missing required argument
correctly so it's giving you a partitioning error instead of a syntax error when
reading the kickstart file.

This will be fixed in the next version pykickstart in devel, and in the next
major release of RHEL.  If you require this fix in an update release of RHEL,
please contact your support representative who will raise this issue through the
appropriate channels.

Comment 2 Levente Farkas 2007-08-10 08:25:12 UTC
how do you know about that param and it's format? i can't find any info about it:-(

Comment 3 Chris Lumens 2007-08-10 14:22:00 UTC
http://fedoraproject.org/wiki/AnacondaKickstart


Note You need to log in before you can comment on or make changes to this bug.