Bug 251322 - back button skips every other option
back button skips every other option
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 07:52 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 15:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-08-08 07:52:27 EDT
Using the forward/back buttons at firstboot does not allow SELinux options do be
changed - it is silently skipped.
Comment 1 Chris Lumens 2007-08-08 10:42:38 EDT
Are you seeing a traceback appear in a dialog box when firstboot starts?  Is
there a /tmp/firstboot* or /root/firstboot* file?
Comment 2 Need Real Name 2007-08-08 11:51:38 EDT
I don't remember seeing any traceback. Certainly no dialog box appears.

I've gone past firstboot now, so can't check for those files.

You *can* change the SELinux options, but as soon as you push "Next", pushing
"Previous" on the next screen skips SELinux for the option before.
Comment 3 Need Real Name 2007-08-09 06:24:42 EDT
It seems that the back button actually jumps over/skips every other completed
option.
Comment 4 Chris Lumens 2007-08-09 15:18:46 EDT
Hm, I'm not seeing this.  Is there any other information you can think of that
would be helpful in debugging this?
Comment 5 Need Real Name 2007-08-09 15:40:10 EDT
I am running this from a VMware machine.
Perhaps you could run it from there too?
 http://www.thoughtpolice.co.uk/vmware/#fedora8t1

I can send you the activation code if you want it.
Comment 6 Chris Lumens 2007-08-14 10:54:19 EDT
This may be due to irregularities in vmware input handling, such that it's
receiving double the mouse clocks or something like that.  Are you able to
reproduce this on regular hardware?  I have not seen this here, nor has anyone
in QA.
Comment 7 Need Real Name 2007-08-14 11:31:51 EDT
Irregularities that only occur during firstboot? Hm..

Wouldn't that be a vmware mouse drive issue in Fedora then?

I'll manually run firstboot again (if it will let me) and see what happens.
I don't have any physical hardware to test this on.
Comment 8 Chris Lumens 2007-08-14 11:35:52 EDT
Yeah, I'll admit we're just reaching for things here.  However I've had several
people test this out on fresh installs and no one has run into this problem, nor
have I seen any other bugs about this issue.  It seems to me that it must be
something unique to your setup, and vmware is what immediately comes to mind.
Comment 9 Need Real Name 2007-08-14 11:49:08 EDT
Running firstboot manually works fine (but tested over vnc..)
Comment 10 Chris Lumens 2007-08-14 11:55:08 EDT
When you say that running it manually works, do you mean that you are running it
from a command line still inside vmware?
Comment 11 Need Real Name 2007-08-14 11:58:05 EDT
Running firstboot from a fresh install (in vmware) works (also over vnc).

I will say that it _did_ skip over License Information once, but I can't
reproduce that.

What next? :)
Comment 12 Need Real Name 2007-08-14 11:59:39 EDT
(In reply to comment #10)
> When you say that running it manually works, do you mean that you are running it
> from a command line still inside vmware?

$ ssh -CX hostname
$ vmware&
$ vncviewer

then start Workstation, "boot" F8T1, edit /etc/sysconfig/firstboot, then run
firstboot.
Comment 13 Chris Lumens 2007-10-02 15:10:34 EDT
We are unable to reproduce this with F8 test 2 under vmware.  Feel free to
reopen this bug if you test with a later release and are still seeing this problem.

Note You need to log in before you can comment on or make changes to this bug.