Bug 25133 - 'Run shell command' key binding doesn't work
Summary: 'Run shell command' key binding doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-28 13:16 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 01:22:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2001-01-28 13:16:36 UTC
In Red Hat Linux 7 I was able to get the 'Run program' (foot->Run...)
dialog to appear when I pressed Ctrl-shift-r, I *think* by default rather
than by changing the configuration.

Now it doesn't work, and I can't even configure it to work.  I have:

C-R   Run shell command:

But pressing the key combo just temporarily removes focus from the active
window and then gives it back.

In fact, I can't get C-R to do _anything_.

Comment 1 Glen Foster 2001-01-30 00:05:49 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Tim Waugh 2001-01-30 14:06:55 UTC
If I downgrade to sawfish-0.34-1 it works.

Comment 3 Havoc Pennington 2001-02-03 05:12:27 UTC
Odd, the key binding is actually in the panel as far as I know, but swapping
Sawfish versions makes it work... the configuration for this is in "Global
Properties" for the panel.

Comment 4 Havoc Pennington 2001-02-06 01:22:15 UTC
Problem here is that the panel was reading the key event from uninitialized
memory that happened to be used previously for a similar key event, since the 
two were adjacent in the event queue or something, so the panel was completely
broken but worked through dumb luck. Recent Sawfish versions through some
unrelated change insert an extra event in the queue and disrupt the mysterious
alignment of planets that allowed the broken panel to miraculously work.
Upstream maintainer for gnome-core is sending me a patch.

Comment 5 Havoc Pennington 2001-02-07 20:16:37 UTC
I'm building a fixed package now.


Note You need to log in before you can comment on or make changes to this bug.