Bug 251334 - `_XmStrings' has different size in shared object in libXm.so.2 compared to openmotif
`_XmStrings' has different size in shared object in libXm.so.2 compared to op...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 09:39 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 17:15:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-08-08 09:39:32 EDT
Description of problem: The NMR data analysis program, Felix 2004, formerly from
Accelrys and now sold by FelixNMR, exposes a binary compatibility flaw in the
libXm.so.2 shared library of lesstif.


Version-Release number of selected component (if applicable):
lesstif-0.95.0-15.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install Felix 2004 on Fedora 7
2. Execute FelixX to start Felix 2004.
  
Actual results:
Felix 2004 segfaults with the error...

>felixX: Symbol `_XmStrings' has different size in shared object, consider
re-linking
>Executing:  '/usr/accelrys/Felix2004/macros/felix/menus/mac/init.mac'
>Xt Error: Widget title has zero width and/or height
>Xt Error: Widget right has zero width and/or height
>Xt Error: Widget left has zero width and/or height
>Xt Error: Widget bottom has zero width and/or height
>Xt Error: Widget top has zero width and/or height

I have also filed this in the bugzilla for lesstif as...

[ 1770036 ] lesstif incompatible with Accelrys' Felix 2004

Expected results:
I expected Felix 2004 to run normally.

Additional info:
Felix 2004's home page is http://www.felixnmr.com/
Comment 1 Patrice Dumas 2007-08-08 09:50:32 EDT
lesstif and openmotif are not ABI compatible, so if felix
was compiled against openmotif it is normal to get the segfault.

felix should be recompiled against lesstif by Accelrys'. if 
that fails it is a bug.

Even if it compiles it is not completly certain that it will
run since some part of the openmotif API are not implemented
for real, but this may only be revealed during the run. Most
of the API is implemented, though.
Comment 2 Hans de Goede 2007-08-28 17:08:15 EDT
Erm, since as you have already correctly stated, lesstif does not advertise
binary openmotif compatibility, shouldn't this bug be closed?
Comment 3 Patrice Dumas 2007-08-28 18:03:08 EDT
I leave some time for the Reporter to close the bug himself
or respond, I'll close it later if no response.

Note You need to log in before you can comment on or make changes to this bug.