Bug 251339 - Kernel 2.6.22.1-41.fc7 hangs on boot with a LSI53C1030 SCSI card
Kernel 2.6.22.1-41.fc7 hangs on boot with a LSI53C1030 SCSI card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 10:12 EDT by 260795
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 15:35:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description 260795 2007-08-08 10:12:46 EDT
Description of problem:

The latest stock kernel hangs most of the times while booting on an HP ML110
Server equipped with a LSI Logic 53C1030 SCSI adapter

Version-Release number of selected component (if applicable):

kernel-2.6.22.1-41.fc7.i686.rpm
kernel-2.6.22.1-41.fc7.i586.rpm

Tried both, same result.

How reproducible:

Most of the times. On average it hangs 4 out of 5 boot attempts.

Steps to Reproduce:

Upgraded from fc5 to fc7. Upgraded to the latest kernel. Rebooted.
  
Actual results:

Bootup hangs most of the times.

Expected results:

Regular bootup sequence.

Additional info:

While booting the kernel hangs within nash. The latest available message is:

Setting up hotplug

I'm still able to reboot with ctrl-alt-del, so it isn't a true kernel oops but a
driver loaded by nash which stops responding. 

After a bit of fiddling with initrd I've been able to find that hotplug has
nothing to do with the hang-up. After removing the hotplug step from the init
script, nash show further messages (buffering problems?) up to:

mptbase: Initiating ioc0 bringup

Then nothing happens. 

I downgraded the kernel to kernel-2.6.20-1.2962.fc6.i686.rpm (fc6 latest), which
has an older MPT driver, and everything works as expected.
Comment 1 Chuck Ebbert 2007-08-08 13:18:23 EDT
Does the kernel option "pci=nomsi" make a difference?
Comment 2 Sammy 2007-08-10 10:36:23 EDT
I am running kernel-2.6.22.1-41.fc7.i686.rpm on a DELL Precision 350 with:

     Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)

fine. dmesg sais:

     Fusion MPT base driver 3.04.04
     Copyright (c) 1999-2007 LSI Logic Corporation
     Fusion MPT SPI Host driver 3.04.04
 
Modprobe.conf has:
     alias scsi_hostadapter mptbase
     alias scsi_hostadapter1 mptspi

Kernel line in grub.conf has no extra options. FYI


Comment 3 Sammy 2007-08-10 10:37:34 EDT
PS: I had similar hangs with this system in the past when I connected an
    external SCSI device. Do you have any?
Comment 4 260795 2007-08-10 14:17:48 EDT
Sorry for being so late, I've been out of office. I tried with "pci=nomsi", but 
it seems to make no difference. 

I can't attach external devices, there's no connector. Probably it is the same 
chipset but a different adapter model. 

BTW dmesg, with the fc6 kernel, reports this:

Fusion MPT base driver 3.04.03
Copyright (c) 1999-2007 LSI Logic Corporation
Fusion MPT SPI Host driver 3.04.03
ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 24 (level, low) -> IRQ 18
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator,Target}
scsi0 : ioc0: LSI53C1030, FwRev=01032700h, Ports=1, MaxQ=255, IRQ=18

When it started with the fc7 kernel it reported this:

Aug  8 14:47:00 server kernel: Fusion MPT base driver 3.04.04
Aug  8 14:47:01 server kernel: Copyright (c) 1999-2007 LSI Logic Corporation
Aug  8 14:47:01 server kernel: Fusion MPT SPI Host driver 3.04.04
Aug  8 14:47:01 server kernel: ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 24 (le
vel, low) -> IRQ 17
Aug  8 14:47:01 server kernel: mptbase: Initiating ioc0 bringup
Aug  8 14:47:01 server kernel: ioc0: 53C1030: Capabilities={Initiator,Target}
Aug  8 14:47:01 server kernel: scsi0 : ioc0: LSI53C1030, FwRev=01032700h, Ports=
1, MaxQ=255, IRQ=17

The difference in the IRQ it's because in the meantime I disabled the USB chip, 
just to see if it made a difference, so the SCSI adapter got assigned a 
different IRQ. Then I left it disabled, we have no USB devices attached, but it 
makes no difference at all. Apart from the IRQ and the different driver version 
they look to be the same.
Comment 5 260795 2007-08-10 14:21:11 EDT
Furthermore, modprobe.conf has only one line referring to SCSI:

alias scsi_hostadapter mptspi

Does it make any difference?
Comment 6 260795 2007-08-22 08:30:19 EDT
After a lot of fiddling with kernels going from 2.6.18 to the latest
2.6.22.2-57.fc7 test kernel I found the source of the problem. First of all I
got many different kind of apparently unrelated problems apart form the boot one
described above, ranging from parallel ports not working to hangs on serial port
detection, to pnp device activation problems.

After adding an "acpi=off" boot option everything started working perfectly,
with any of the kernels tested. Now I'm using the official 2.6.22.1-41.fc7.

I've found on Internet that there are many broken ACPI bioses around. Probably
my HP ML 110 has one of them. After all it's a server and not even one the most
recent. If there's an interest in finding workarounds for the problem I can
supply any desired information about the hardware configuration and the ACPI
bios used by my server.

Thanks anyway for your support and your help.
Comment 7 Chuck Ebbert 2007-08-22 15:35:19 EDT
Other than trying to see if a BIOS update fixes the problems, there probably
isn't much more to try.

Note You need to log in before you can comment on or make changes to this bug.