Bug 251371 - CDROM test fails with GSA-H60L DVD writer
CDROM test fails with GSA-H60L DVD writer
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: YangKun
Depends On:
  Show dependency treegraph
Reported: 2007-08-08 12:29 EDT by Gregory Feiner
Modified: 2008-07-16 17:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-11 23:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
log of the test results. CDROM was attempted on runs 3,4,and 5. (1.96 MB, application/octet-stream)
2007-08-08 12:29 EDT, Gregory Feiner
no flags Details
hts5.1 CDROM failure (1.96 MB, application/octet-stream)
2007-10-15 16:57 EDT, Gregory Feiner
no flags Details
2nd try at HTS 5.1 CDROM test (375.72 KB, application/octet-stream)
2007-10-25 17:19 EDT, Gregory Feiner
no flags Details
console output during failing CDRW (9.83 KB, text/plain)
2007-10-26 15:40 EDT, Gregory Feiner
no flags Details
console output during passing CDRW (7.54 KB, text/plain)
2007-10-26 15:40 EDT, Gregory Feiner
no flags Details
console output during failing DVDRW (7.33 KB, text/plain)
2007-10-26 15:40 EDT, Gregory Feiner
no flags Details
more results (375.72 KB, application/octet-stream)
2007-10-26 15:41 EDT, Gregory Feiner
no flags Details
more results (408.13 KB, application/octet-stream)
2007-10-26 15:41 EDT, Gregory Feiner
no flags Details
pasing cdrw-failing dvdrw (435.58 KB, application/octet-stream)
2007-10-26 15:42 EDT, Gregory Feiner
no flags Details
passing and failing runs using GA release OS and test kit. (788.18 KB, application/x-zip-compressed)
2007-11-01 17:07 EDT, Gregory Feiner
no flags Details

  None (edit)
Description Gregory Feiner 2007-08-08 12:29:54 EDT
Description of problem:
When testing the HP SATA Super Multi DVD ReWriter, model GSA-H60L (A2CH) 
(firmware E903), the test fails with either a input/output error during the 
compare or a "file not found error" during the compare on the CD-RW portion of 
the test.  Since CD-RW is the first media it tests, the test does not continue 
on to DVD-RW media.

-----Original Message-----
From: Chris Williams [mailto:cww@redhat.com] 
Sent: Tuesday, August 07, 2007 3:20 PM
To: Feiner, Gregory (ISS-IST)
Subject: Re: CDROM test under RHEL5 U1 Beta1

On Tue, 2007-08-07 at 18:46 +0000, Feiner, Gregory (ISS-IST) wrote:
> Chris,
> I’m testing the same sata CD+-RW/DVD+-RW/DVD DL/lightscribe drive that
> we discussed earlier where I had to run the tests manually under RHEL
> 4.  Now I’m testing the drive under RHEL 5 U1 Beta 1 using  release 48
> of hts and I’m having trouble.  The test is failing during CD-RW
> testing which causes the test not to continue on to DVD-RW testing. 
> The failure is either a Input/Output error during the compare, or a
> “file not found” error during the compare. 
> I’ve made two observations:
>      1. The “file not found” error only happens if the CD-RW being
>         used for testing is either brand new or erased before hand.
>         Furthermore, even though the log says the disc write was
>         successful, the disc appears incomplete and unmountable.
>      2. The input/output error only happens if the CD-RW being used is
>         not blank.  And when the write finishes in this case, the disc
>         is readable/mountable.
> I have attached the log file.  Runs 3, 4, and 5 are the CD test runs.
> Run 3: CD-RW used was not blank.
> Run 4: Same CD-RW from run 3, but I erased the disc before testing.
> Run 5: I used a brand new, blank CD-RW disc.
> Take a look at the logs and tell me what you think.  Will I need to
> run the record and compare manually just like I did for RHEL 4?

Indeed, worked with Steve Cormack on this same drive.

Open a BZ against HTS with your findings, they gotta fix these optical



Version-Release number of selected component (if applicable): HTS release 48, 
RHEL5 U1 Beta1.

How reproducible: Every time.

Steps to Reproduce:
1.run the CDROM test against this drive.

Actual results: Either fails due to input-ouput error or "file not found" 

Expected results: should pass.

Additional info:
Comment 1 Gregory Feiner 2007-08-08 12:29:56 EDT
Created attachment 160919 [details]
log of the test results.  CDROM was attempted on runs 3,4,and 5.
Comment 2 YangKun 2007-10-08 05:20:36 EDT
please use HTS5.1 to certify RHEL5.1(RHEL5.1 should be certified using HTS5.1,
not HTS5.0). And please use RC or GA versions of RHEL5.1 for HwCert purpose,
please do not use beta versions of RHEL.

please let me know if HTS5.1 still has this issue on RHEL5.1 .

Thanks very much!
Comment 4 Gregory Feiner 2007-10-15 16:57:35 EDT
Created attachment 227901 [details]
hts5.1 CDROM failure
Comment 5 Gregory Feiner 2007-10-15 16:58:33 EDT
I retested with hts 5.1-3 and RHEL5.1 RC. The test still failed.
Comment 6 YangKun 2007-10-25 12:01:26 EDT
there are 3 CDROM runs in the attached rpm, all failed, and the errors are:
cmp: media/./nmblookup: Input/output error

cmp: media/./nmblookup: No such file or directory

cmp: media/./nmblookup: No such file or directory

and the result shows you were still using hts-5.0-48 for testing:
<certification-test discover-time='2007-08-02 10:47:05' plan-time='2007-08-02
10:47:05' hts-release='48' hts-version='5.0'>

could you please confirm ?

the correct steps to remove hts-5.0-48 and install hts5.1 are:
    1) hts clean // type "yes" twice
    2) rpm -e hts-5.0-48
    3) rm -rf /usr/share/hts/
    4) rpm -ivh hts-5.1-XXX.rpm

Comment 7 Gregory Feiner 2007-10-25 17:19:32 EDT
Created attachment 238081 [details]
2nd try at HTS 5.1 CDROM test
Comment 8 Gregory Feiner 2007-10-25 17:21:30 EDT
Attachment ID 238081 is from a fresh install of the OS and HTS 5.1-3.  It still 
failed.  I used brand new media.  It didn't get past the first part of the test 
Comment 9 YangKun 2007-10-26 06:53:13 EDT
The error is "No such file or directory: 'media/runcon'". 

Which shows that one file(/usr/bin/runcon) is not written to the cd-rw disc,
have you done some package install/un-install while the CDROM test was running ?

Could you please confirm if the file "/usr/bin/runcon" exists on your test
machine and is accessible, then could you please re-run the CDROM test again ?
And please do not run other commands or programs(especially not to 
install/un-install software) while the CDROM test is running.

Comment 10 Gregory Feiner 2007-10-26 15:39:19 EDT
I didn't do any package installs, uninstalls or anything else while the CDROM 
test was running.  /usr/bin/runcon exists and is accessible/runnable.   

I ran it again using a brand new, Maxell 700MB blank CD-RW.  It still failed 
with an error regarding 'media/runcon'. After the test completed, I looked that 
contents of the CD-RW.  It did indeed contain runcon.  

I ran the test yet again using the same CD-RW disc (so the disc was not blank 
to begin with). The CD-RW portion of the test passed, but the DVDRW portion of 
the test failed.  So if I begin the test with a disc that is blank, the test 
will fail. If I begin the test with a disc that is not blank, the test will 

The DVDRW I used was not blank so I expected it to pass (like the CDRW did). 
The console output during the compare of the DVDRW complains "Permission 
denied: 'media/man/sl/man5/man.config.5.gz'".  I looked at the contents of the 
DVD after the write. That is not a valid file name.  The closest I could find 
on the DVD was man/sl/man5/man_conf.gz.

When I first submitted this issue, I noted how the test behaved differently 
depending on whether or not I started with blank media. So there is no change 
in that area from hts 5.0 to hts 5.1.  Test kit bug??

I have attached test results as well as the console output during those runs.

Do you have one these drives to test with yourself?  If not, maybe we need to 
send you guys one of these drives so this can be put to rest.
Comment 11 Gregory Feiner 2007-10-26 15:40:03 EDT
Created attachment 239451 [details]
console output during failing CDRW
Comment 12 Gregory Feiner 2007-10-26 15:40:29 EDT
Created attachment 239461 [details]
console output during passing CDRW
Comment 13 Gregory Feiner 2007-10-26 15:40:59 EDT
Created attachment 239471 [details]
console output during failing DVDRW
Comment 14 Gregory Feiner 2007-10-26 15:41:39 EDT
Created attachment 239481 [details]
more results
Comment 15 Gregory Feiner 2007-10-26 15:41:54 EDT
Created attachment 239491 [details]
more results
Comment 16 Gregory Feiner 2007-10-26 15:42:31 EDT
Created attachment 239501 [details]
pasing cdrw-failing dvdrw
Comment 17 YangKun 2007-10-31 05:42:53 EDT
Hi Gregory,

The "Permission denied" error is really strange. Have you done some system
configurations after the OS-install ?

I still can not re-produce this error. I tested all CD-RW/DVD-RW/DVD+RW with
HTS5.1 and RHEL5.1, all works well for me.

RHEL5.1 GA is released, could you please install the GA version of
RHEL5.1-Server(using the default firewall rules and default SELinux policy) and
use the latest HTS5.1, then run the CDROM test one more time ? see if there're
still errors. And please make sure not to run any other commands/program while
the cdrom test is running.

Thank you very much!
Comment 18 Gregory Feiner 2007-10-31 11:48:03 EDT
We are trying to locate the GA build. The latest version of RHEL51 we see on 
RHN is RC2.  

I did not do any system reconfigurations after the OS install.  I did a 
standard OS installation, installing all packages except virtualization and 
languages other than english.  Then I installed the test kit and ran the test.  
I did not do anything with the OS while the test is running.

You said you tried to reproduce the error.  I'm assuming this means you are 
using the same model of drive (GSA-H60L), correct?  If so, what firmware 
revision does your drive have?  Mine is version E903.  Firmware revision should 
be noted somewhere on the manufacturer label.  If you are not using the GSA-
H60L, please try to repro with that exact model of drive.
Comment 19 Gregory Feiner 2007-11-01 17:05:32 EDT

I ran the test again, but did 3 thing this time:
1. Updated to the GA release of RHEL5.1
2. Updated the firmware on the writer drive from E903 to E904
3. Updated from hts 5.1-3 to 5.1-11.

I ran the test two times (and did not do anything during the test or make any 
configuration changes to the OS).

During the first run, I used -RW media that was not blank (already had data on 
it) and the test passed.

During the 2nd run, I used the same brand of media, but it was brand new and 
blank.   The test failed during the compare saying it can't 
find "xmlproc_val".  I searched the CD after the test failed. I couldn't find a 
file by that name, but I did find a file called xmproc_

So if the media used is blank, test will fail.  If the media is not blank, test 
will pass.

I have attached log files and console output of this attempt in a single zip 
Comment 20 Gregory Feiner 2007-11-01 17:07:02 EDT
Created attachment 246081 [details]
passing and failing runs using GA release OS and test kit.
Comment 21 YangKun 2007-11-05 05:06:43 EST
Hi Gregory,

Do you mean the test can PASS with used DVD-RW/CD-RW media and will FAIL with
brand new DVD-RW/CD-RW disks ?

I got no un-used disks in hand. I'll try to get some and see if I can re-produce
this error ASAP.

Comment 22 Gregory Feiner 2007-11-07 10:49:19 EST
Yes, that is what I mean.  blank media or brand new -->fail.  Non-blank media--
Comment 23 YangKun 2007-11-07 22:12:54 EST
Hi Gregory,

I still can not re-produce your error. I tested hts-5.1-11 on RHEL5.1-Server GA,
with both brand new CD-RW/DVD-RW disks and non-blank CD-RW/DVD-RW disks, the
test ran well for me, the disks I used are:
  o brand new CD-RW disk : UNIS CD-RW 4x
  o brand new DVD-RW disk: SONY DVD-RW 1x-2x (DMW47S2)
  o non-bland CD-RW disk : TDK CD-RW 4x-12x High Speed (CD-RW80HS)
  o non-bland DVD-RW disk: TDK DVD-RW 1x-2x

I do not have the "GSA-H60L DVD writer", and I tested on a "PHILIPS DVD+/-RW
DVD8801" drive.

Could this be a GSA-H60L DVD writer's issue instead of an HTS's issue ?

Comment 24 Gregory Feiner 2007-11-08 11:21:30 EST
I was using a Maxell CD-RW and a Memorex 2x DVD-RW.  I'll try different media.  
Since the test is working with your writer, it may be a problem with this 
particular drive.
Comment 25 YangKun 2007-11-08 21:35:39 EST
Please let me know if you have any update. 

Thanks very much.
Comment 26 Gregory Feiner 2007-11-09 16:45:27 EST
I tried some sony media and it worked fine.  This drive is picky about brands 
of media.  This issue can be closed.
Comment 27 Rainer Koenig 2007-12-06 08:44:28 EST
I'd suggest to reopen this bug. I had similar problems with the cdrom test on
various DVD-writers using various media until I discovered by accident that the
test will pass when I use an "used" media.

My suspect is that blanking a blank media confuses the system. The problem in
that case is that the media is not mounted correctly before starting the compare
routines. mount doesn't show anything and if you try to execute

mount /dev/cdrom /media 

you'll be asked to specify a file system type for the mount.

If you eject the tray and close it again with the very same media then you can
mount it without specifying a fs type and you can find all the files written to it. 

Maybe the cdrom test should do some eject/close action on the tray so that the
mount is working correctly. 

Comment 28 YangKun 2007-12-06 22:35:22 EST
the interesting thing is I can not re-produce your issues with serveral of my
DVD-writers and DVD-/+RW disks. 

Could you please ship me one of the DVD-writer you use for investigation ?


Note You need to log in before you can comment on or make changes to this bug.