Bug 251393 - X catch signal 11 with xorg-x11-drv-ati.6.6.193-1
X catch signal 11 with xorg-x11-drv-ati.6.6.193-1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 14:33 EDT by Samuel Bizien
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 6.6.193-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 10:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile (27.72 KB, application/octet-stream)
2007-08-08 14:33 EDT, Samuel Bizien
no flags Details

  None (edit)
Description Samuel Bizien 2007-08-08 14:33:03 EDT
Description of problem:
With last driver from Rawhide, X can't start (Xorg logfile joined). Driver
"radeon" doesn't work, i have to use "vesa".

Version-Release number of selected component (if applicable):
6.6.193-1.fc8

How reproducible:
Just yum install 6.6.193-1.fc8 and reboot.

  
Actual results:
Last lines from Xorg.0.log :
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
[...]

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6d) [0x47febd]
1: /lib64/libc.so.6 [0x2aaaab39b870]
2:
/usr/lib64/xorg/modules/drivers//radeon_drv.so(RADEONSetSyncRangeFromEdid+0x18)
[0x2aaaacadc3f8]
3: /usr/lib64/xorg/modules/drivers//radeon_drv.so [0x2aaaacace385]
4: /usr/lib64/xorg/modules/drivers//radeon_drv.so(RADEONPreInit+0xac6)
[0x2aaaacad1586]
5: /usr/bin/X(InitOutput+0x9ad) [0x463a8d]
6: /usr/bin/X(main+0x275) [0x4346e5]
7: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaab388cc4]
8: /usr/bin/X(FontFileCompleteXLFD+0x239) [0x433b99]

Fatal server error:
Caught signal 11.  Server aborting
EOF

Expected results:
Just work.

Additional info: I'm using rawhide, on a x86_64 proc. My videocard is "Radeon
9600 XT", and have nevver touched my xorg.conf before today (to use vesa driver,
since radeon bugs).
Comment 1 Samuel Bizien 2007-08-08 14:33:03 EDT
Created attachment 160926 [details]
Xorg logfile
Comment 2 Samuel Bizien 2007-08-09 12:51:47 EDT
With release 2, it works.
Comment 3 Matěj Cepl 2007-08-15 10:33:30 EDT
closing per comment 2.

Note You need to log in before you can comment on or make changes to this bug.