Bug 251400 - make find-lang.sh --with-gnome pick up omf files
make find-lang.sh --with-gnome pick up omf files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 14:44 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 05:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (573 bytes, patch)
2007-08-08 14:44 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2007-08-08 14:44:38 EDT
I've started using find-lang --with-gnome in spec files now, in the hope of
using _install_langs to reduce the size of live cds. It would be nice if
--with-gnome would not only pick up the help files in /usr/share/gnome/help,
but also the omf files in /usr/share/omf that go with them. 

The patch does just that. If you are worried about compatibility, we could
also make that depend on a new --with-omf option, but I don't really think
that is necessary.
Comment 1 Matthias Clasen 2007-08-08 14:44:38 EDT
Created attachment 160927 [details]
patch
Comment 2 Matthias Clasen 2007-08-08 15:46:41 EDT
Jeremy also proposes to make --with-gnome --with-kde the default in our %find_lang 
macro.
Comment 3 Panu Matilainen 2007-08-10 08:02:37 EDT
I suppose it'd be good to have --with-omf to be in line with the other cases
but... I wonder what has been the real point of all the --with-gnome etc options
in the first place.
Comment 4 Matthias Clasen 2007-08-10 09:29:43 EDT
The point is to get %lang tagging for all the big locale-dependent files, so that
_install_langs can do its magic. The documentation under gnome/help is the reason
why evolution is the second-largest package on the live cd...
Comment 5 Panu Matilainen 2007-08-10 09:40:10 EDT
Yes, I can see that :) I'm just wondering why those --gnome etc things have bee
optional to begin with if they dont break anything.

To make it clear, I'm not opposed to this or anything, just curious.
Comment 6 Matthias Clasen 2007-08-10 09:51:54 EDT
Good question. 

The only slight concern is that turning it on by default now will cause
duplication between foo.lang and the explicit file list, with one entry
having a %lang tag, the other not. But I assume that rpm will handle that
correctly.
Comment 7 Panu Matilainen 2007-08-15 05:51:01 EDT
Hey, this is rpm - assumptions are inherently dangerous :) I don't actually know
what will happen in such a case, but the worst that can happen is that
duplicates (which you'll get warned about) dont get treated as lang-files. Which
is harmless as it's no worse than what was before.

As for the patch itself, upstream at rpm.org and building right now into
rawhide, will be in rpm-4.4.2.1-8.fc8. I've been totally blind and missed the
fact that the .omf files were only searched when --with-gnome was specified,
that's safe enough for me. Thanks for the patch :)

Turning --with-kde and --with-gnome on by default in redhat-rpm-config is out of
my control, but I'm in no way opposed to that.

Note You need to log in before you can comment on or make changes to this bug.