Bug 251412 - NPEs in autotools plugin
NPEs in autotools plugin
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 15:48 EDT by Ben Konrath
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 17:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
consolelog output (5.28 KB, text/plain)
2007-08-08 15:48 EDT, Ben Konrath
no flags Details
new stack trace (25.44 KB, text/plain)
2007-08-09 15:29 EDT, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2007-08-08 15:48:45 EDT
Description of problem:

There are a couple of NPEs in the autotools plugin after I check out a GNOME
project from svn.

Version-Release number of selected component (if applicable):

eclipse-cdt-3.1.2-3.fc7.x86_64

Steps to Reproduce:
1. check out gok from GNOME cvs
2. let autotools plugin run the build
3. see NPEs on console
Comment 1 Ben Konrath 2007-08-08 15:48:45 EDT
Created attachment 160931 [details]
consolelog output
Comment 2 Jeff Johnston 2007-08-08 16:57:56 EDT
Please try eclipse-cdt-3.1.2-6 which is found in Fedora updates-testing.  I have
tried this on my x86 F7 laptop using java 1.5.0_08 and am able to build gok once
I installed the prerequisite packages.
Comment 3 Ben Konrath 2007-08-09 15:29:02 EDT
Created attachment 161009 [details]
new stack trace

Ok, I tried the new version and I now get these errors. Also, my build failed
with this:

Generating Makefile

/home/bkonrath/workspace/gok/configure 
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: error: source directory already configured; run "make distclean"
there first

Configuration failed with error

How can I do a 'make distclean' within Eclipse?
Comment 4 Jeff Johnston 2007-08-14 17:02:29 EDT
The SWT error you quoted above is new.  It has to do with an API that Autotools
uses to set the builder which documents that null passed for an operation
monitor indicates monitoring is not desired.  This turns out to be false and an
attempt is made to see if the operation is cancelled.  The code has just been
modified to pass a NullProgressMonitor which will avoid the assertion failure
and accomplish the same thing.  

Regarding the make distclean.  The current Autotools Plugin will create
MakeTargets for the top-level Makefile on behalf of the user once the Makefile
gets created sucessfully.  On F7 and below, these targets are found in the Build
Special Targets action of the Project menu.  For F8 (CDT 4.0.0), there is a Make
Targets action found in the Project menu which is the same thing.  

In the case where configuration was not performed sucessfully and the top-level
Makefile was not created properly, one may have to use the command line to
perform actions other than deletion, moving, or invoking the autotools.  A
reconfiguration can be caused by changing the configuration options in the
Project properties.  One can also manually delete the config.status file plus
the Makefile, etc...
Comment 5 Fedora Update System 2007-08-17 12:12:18 EDT
eclipse-cdt-3.1.2-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.