Bug 251441 - virt-install fails to install guest
virt-install fails to install guest
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 23:07 EDT by Adam Greenberg
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 23:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Greenberg 2007-08-08 23:07:23 EDT
Description of problem:
virt-install fails to install a fedora 7 guest.  I specify the following:

[root@boris Download]# virt-install
virt-install
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. yes
yes
 What is the name of your virtual machine? fc7
fc7
 How much RAM should be allocated (in megabytes)? 1500
1500
 What would you like to use as the disk (path)? /var/lib/xen/images/fc7
/var/lib/xen/images/fc7
 How large would you like the disk (/var/lib/xen/images/fc7) to be (in gigabytes)? 8
8
 Would you like to enable graphics support? (yes or no) yes
yes
 What is the virtual CD image, CD device or install location?
/home/moose/Download/F-7-i386-DVD.iso 
/home/moose/Download/F-7-i386-DVD.iso 
 

Starting install...
libvir: Xen Daemon error : GET operation failed: 
libvir: Xen Daemon error : GET operation failed: 
Creating storage file...  100% |=========================| 8.0 GB    00:00     
Creating domain...                                                 0 B 00:01 

VNC Viewer Free Edition 4.1.2 for X - built Jun 11 2007 09:44:37
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Wed Aug  8 22:28:21 2007
 CConn:       connected to host localhost port 5901
 CConnection: Server supports RFB protocol version 3.3
 CConnection: Using RFB protocol version 3.3
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding
 CConn:       Throughput 10000 kbit/s - changing to hextile encoding
 CConn:       Throughput 10000 kbit/s - changing to full colour
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using hextile encoding
Domain installation still in progress.  You can reconnect to 
the console to complete the installation process.
[root@boris Download]#

I see the guest domain created (in the manager) and I get what appears to be a
vnc window for the console.  However, it blinks with a bit of the startup screen
 text and then goes black where it remains.  The domain continues to run.  Here
is the qemu log output:

domid: 22
qemu: the number of cpus is 1
Watching /local/domain/22/logdirty/next-active
qemu_map_cache_init nr_buckets = 10000
shared page at pfn 5dbff
buffered io page at pfn 5dbfd
xs_read(/vm/ffd46af4-2ec6-53c3-bea2-bab4e93004c5/rtc/timeoffset): read error
xs_read(): vncpasswd get error. /vm/ffd46af4-2ec6-53c3-bea2-bab4e93004c5/vncpasswd.
char device redirected to /dev/pts/2
I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0
Triggered log-dirty buffer switch

I can achieve the same state by using the creation wizard in the manager.

I tried turning off the firewall but this error behavior still occurs. I find
that I can attach to this computer via VNC from another computer with no
problems (with or without the firewall).

Version-Release number of selected component (if applicable):
libvirt-0.3.1-2.fc7
xen-3.1.0-2.fc7
vnc-4.1.2-18.fc7



How reproducible:


Steps to Reproduce:
1.  See above.
2.
3.
  
Actual results:
New domain, black console window - failed installation.

Expected results:
New domain, active console that allows the installation to complete.

Additional info:
Comment 1 Daniel Berrange 2007-09-06 23:24:27 EDT
I'm afraid this bug is a fatal problem in the Fedora 7 installation media. The
bare metal F7  install kernel fails under Xen :-(   If you need to install F7
then you'll have to use paravirt instead I'm afraid. Since the bug was in the
install media there's no way to provide an updated kernel with a fix, and we've
been unable to do a workaround hack in Xen itself.

If you don't want paravirt, then another option again is to use KVM instead of
Xen, which isn't impacted by the bug in F7 kernels. I'd recommend Xen paravirt
for performance though.
Comment 2 Adam Greenberg 2007-09-06 23:39:29 EDT
Thanks for the information.  I successfully created a paravirt fc7 guest.  When
I try kvn though, I cannot get passed the vncpasswd problem (even if that is not
the cause).  It get that error
(https://bugzilla.redhat.com/show_bug.cgi?id=253371) regardless of the guest OS
type that I try (fc7 suse, etc).

Note You need to log in before you can comment on or make changes to this bug.