Bug 251446 - Errata showing up under "Clone Errata" after cloning a channel as "Current State" [NEEDINFO]
Summary: Errata showing up under "Clone Errata" after cloning a channel as "Current St...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: 500
Hardware: i386
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2007-08-09 05:07 UTC by William Sizemore
Modified: 2014-05-09 10:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 10:08:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jpazdziora: needinfo? (wsizemor)


Attachments (Terms of Use)

Description William Sizemore 2007-08-09 05:07:35 UTC
Description of problem:
After cloning one of the "RHEL" channels (the ones created when you
'satellite-sync'), even if you choose "Current State of the Channel" to include
cloning all current errata, all errata still show up under "Clone Errata" with a
status of "Not Cloned".  However, the packages for all of the errata are
included in the newly cloned channel.

Version-Release number of selected component (if applicable):
5.0.0

How reproducible:
I have produced this with three satellite server installs (two additional test
installs after finding the problem at a client site).      

Steps to Reproduce:
1.  Clone one of the RHEL channels.
2.  Choose "Current State".
3.  After the clone is finished, click on Errata, then Clone Errata.
4.  No errata should be listed (since all errata should have been cloned along
with the channel) - but all errata are listed.
  
Actual results:
All errata are showing up under "Clone Errata", with "Already Cloned" status of NO.

Expected results:
All errata should have a status of "YES" - and not show up on the Clone Errata
page (unless the "Show cloned errata" box is checked)

Additional info:

Comment 1 Jan Pazdziora 2012-03-15 15:40:37 UTC
Is the problem still present on Satellite 5.4?

Please note that the errata cloning process is asynchronous so it may take a while before the operation finishes even if the HTTP requests already returns to your browser.

Comment 2 Jan Pazdziora 2012-03-15 15:42:13 UTC
Also, fixing the Component -- this is not Configuration Management issue.

Comment 3 Clifford Perry 2014-05-09 10:08:22 UTC
We have not addressed this specific bug in almost 7 years. Closing out as wontfix to clear from backlog. Needinfo for over 2 years.

Please re-open if you disagree and wish further review.

Cliff


Note You need to log in before you can comment on or make changes to this bug.