Bug 251468 - console.perms change required for HPLIP scanning
Summary: console.perms change required for HPLIP scanning
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 251470
TreeView+ depends on / blocked
 
Reported: 2007-08-09 09:54 UTC by Tim Waugh
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 19:34:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pam-scanner.patch (573 bytes, patch)
2007-08-09 09:54 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2007-08-09 09:54:15 UTC
Description of problem:
When using the HPLIP backend to use a scanner, the device permissions need to
allow group ownership of the device node.  This is because the same device node
(the raw USB device) is used both for scanning and printing, and it needs group
lp read-write access.

Version-Release number of selected component (if applicable):
0.99.8.1-3.fc8

How reproducible:
100%

Steps to Reproduce:
1.Plug in an HP multi-function device.
2.Try to print something.
3.Try to scan something.
  
Actual results:
Currently, only printing works.  I have an HPLIP patch to add a 'scanner-%k'
symlink, but if I apply that only scanning works.  Needs this console.perms
patch to make both work.

Expected results:
Can print and scan.

Comment 1 Tim Waugh 2007-08-09 09:54:16 UTC
Created attachment 160960 [details]
pam-scanner.patch

Comment 2 Tomas Mraz 2007-08-09 10:18:07 UTC
As pam_console will/should? be replaced with consolekit for F8, this doesn't
make much sense to add to pam.


Comment 3 Tim Waugh 2007-08-09 10:29:48 UTC
As I understand it, console.perms will continued to be honoured by ConsoleKit.

What's a better solution?

Comment 4 Tomas Mraz 2007-08-09 10:45:19 UTC
IMHO only as a legacy thing. I suppose it will have its own configuration file
but I don't know any details.



Comment 5 Tim Waugh 2007-08-09 10:57:58 UTC
Neither do I.  Until we do, let's just fix this (it's a one-character patch) so
that the new HPLIP can actually get some testing.. :-)

Comment 6 Tomas Mraz 2007-08-09 11:10:01 UTC
OK, OK, you've convinced me :)


Comment 7 Tomas Mraz 2007-08-22 19:34:32 UTC
Fixed in pam-0.99.8.1-5.fc8

The line will actually be:
<console>  0660 <scanner>    0660 root.lp



Note You need to log in before you can comment on or make changes to this bug.