Bug 251484 - Pidgin unable to connect using googletalk protocol
Pidgin unable to connect using googletalk protocol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 08:12 EDT by James Bannon
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 13:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Connect session debug log (9.06 KB, text/plain)
2007-08-09 08:14 EDT, James Bannon
no flags Details

  None (edit)
Description James Bannon 2007-08-09 08:12:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070803 Firefox/2.0.0.6 (Swiftfox)

Description of problem:
I have followed the connection instructions on both googletalk and the Pidgin web site to the letter and it refuses to connect to the googletalk server. I invariably get a "not authorised" error. I have attached the dump of the session.

Version-Release number of selected component (if applicable):
2.1.0-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. Set-up Pidgin with the googletalk account as instructed.
2. Try to connect.
3.

Actual Results:
Error not authorised

Expected Results:
It should have connected to googletalk.

Additional info:
I have tried all the fix attempts available on the Pidgin web site and on google. I have also tried Fedora 8 Live CD Test 1 with exactly the same results (precisely the same debug output).
I have tried disabling firestarter and trying it with both the standard firewall and with no firewall, same results. I can telnet into talk.google.com 5222 and 5223 with no difficulty.
Comment 1 James Bannon 2007-08-09 08:14:52 EDT
Created attachment 160969 [details]
Connect session debug log

Exactly the same output was produced in Fedora 8 Test 1 Live CD
Comment 2 Warren Togami 2007-08-09 17:04:14 EDT
I am connected to Google Talk right now with pidgin-2.1.0-1.fc7 on x86_64.  Have
you found anyone else who experiences this trouble?
Comment 3 James Bannon 2007-08-09 17:39:43 EDT
There are some who are experiencing trouble on the Fedora forums and on the
googletalk group in google groups. Are you using any special settings? Mine are
as given in the dump file:

Sign on name: jamesbannon008
Domain: gmail.com
Host: Host
Password: My own password (which I will not repeat here in plain text form)
Port: 5222
server: talk.google.com

All the rest of the settings are as standard.

The settings for my login id and password work for every other google service
and the talk gadget works from swiftfox and firefox. There is nothing extra
special in the firewall settings that would be causing a problem since by
default all connection attempts initiated by my machine are allowed. In any case
I have tested it with the firewall disabled and get the same results. Maybe a
32-bit bug?
Comment 4 James Bannon 2007-08-10 21:46:15 EDT
Boy, do I feel sheepish! Now it works! It's funny, I have two user names on
google and I'm absolutely positive I tried them both.The long version of my user
name now works. My apologies! This bug can be closed unless someone else is
having difficulties.

Note You need to log in before you can comment on or make changes to this bug.