This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 251490 - Configration values are casted to int
Summary: Configration values are casted to int
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
(Show other bugs)
Version: 500
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 248630
TreeView+ depends on / blocked
 
Reported: 2007-08-09 13:06 UTC by Miroslav Suchý
Modified: 2008-04-02 20:31 UTC (History)
0 users

Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:31:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Suchý 2007-08-09 13:06:48 UTC
Description of problem:
During work on BZ 248890, I found that we try for every key = value, cast value
to int. But this sometime cause trouble. Like proxy.http_proxy_username or
proxy.http_proxy_password.
As I see it can be problem for:
hibernate.connection.username
hibernate.connection.password
osa-dispatcher.jabber_username
osa-dispatcher.jabber_password
Other configuration values should be ok.

Version-Release number of selected component (if applicable):
5.0.0

How reproducible:
always

Steps to Reproduce:
1. setup satellite or proxy behind http proxy 
2. set http proxy name or pass to 0123
  
Actual results:
it will fail

Expected results:
not fail

Additional info:
The problem is in file /usr/share/rhn/common/rhnConfig.py on line 436 in
sanitize function.

Comment 2 Justin Sherrill 2007-10-30 17:16:09 UTC
fixed in rev 133362.

Currently, these values will be always treated as strings:

'proxy.http_proxy_username'
'proxy.http_proxy_password'
'hibernate.connection.username' 
'hibernate.connection.password'
'osa-dispatcher.jabber_username'
'osa-dispatcher.jabber_password'
'server.satellite.http_proxy_username'
'server.satellite.http_proxy_password' 
'server.satellite.rhn_parent' 

Comment 3 Justin Sherrill 2007-11-09 22:30:55 UTC
moving on_qa

Comment 5 Justin Sherrill 2007-12-06 19:02:15 UTC
Hi Preethi,

It may just be easier if you look at the code.  I'm not sure how to have you
test it without setting up a http proxy or modifying the db connection info
(which i don't know how to do).

If you look in /usr/share/rhn/common/rhnConfig.py  at the parse_line function,
you'll see a conversion table that lists all the values listed above along with
the type they should be (str for string).

I then have:
        if converTable.get(key): 
            try:
                val = converTable.get(key)(val)
            except ValueError:
                pass

which says if the key is in the table, convert it to whichever  type it should
be converted to.                                                               
         

Comment 7 Justin Sherrill 2007-12-06 20:01:25 UTC
moving to on_dev after promoting the package to the proxy for the next qa push.

Comment 8 Miroslav Suchý 2007-12-07 08:17:36 UTC
Preethi,
you have test plan writen in my initial comment:

Steps to Reproduce:
1. setup satellite or proxy behind http proxy 
2. set http proxy name or pass to 0123

So in more detail.

1. Install squid on one machine
2. allow only access for user 0123, with pass 0123
3. Install rhn proxy on second machine
4. in /etc/rhn/rhn.conf set:
5. proxy.http_proxy =   to point on first machine with squid
6. proxy.http_proxy_username = 0123
7. proxy.http_proxy_password = 0123

To do it correctly. You should repeat it for jabberd, satellite, hibernate and
osa-dispatcher.

Comment 9 Preethi Thomas 2007-12-13 20:48:02 UTC
verified

Comment 10 Mike McCune 2008-03-26 04:38:04 UTC
works in stage.

Comment 11 Brandon Perkins 2008-04-02 20:31:18 UTC
Proxy 5.1.0 GA so Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.