Bug 251496 - t42 2373 RHEL5 U1 quirks
t42 2373 RHEL5 U1 quirks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.1
i386 Linux
urgent Severity high
: ---
: ---
Assigned To: David Zeuthen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 09:39 EDT by Traxtopel
Modified: 2013-03-05 22:51 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0632
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 13:01:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2373 dmidecode (13.18 KB, text/plain)
2007-08-10 15:36 EDT, Traxtopel
no flags Details
2373 lspci (5.60 KB, text/plain)
2007-08-10 15:36 EDT, Traxtopel
no flags Details
t30-2366-dmidecode (12.61 KB, text/plain)
2007-08-14 12:18 EDT, Traxtopel
no flags Details
t30-2366-lspci (4.83 KB, text/plain)
2007-08-14 12:18 EDT, Traxtopel
no flags Details
a31p-dmidecode (12.61 KB, text/plain)
2007-08-15 14:23 EDT, Traxtopel
no flags Details
a31p-lspci (3.49 KB, text/plain)
2007-08-15 14:24 EDT, Traxtopel
no flags Details
t23-dmidecode (12.29 KB, text/plain)
2007-08-15 20:41 EDT, Traxtopel
no flags Details
t23-lspci (3.57 KB, text/plain)
2007-08-15 20:41 EDT, Traxtopel
no flags Details
x30-dmidecode (11.46 KB, text/plain)
2007-08-15 20:43 EDT, Traxtopel
no flags Details
x30-lspci (3.63 KB, text/plain)
2007-08-15 20:44 EDT, Traxtopel
no flags Details
t60p-dmidecode (13.10 KB, application/octet-stream)
2007-08-15 20:45 EDT, Traxtopel
no flags Details
t60p-lspci (7.04 KB, text/plain)
2007-08-15 20:45 EDT, Traxtopel
no flags Details
x30-dmidecode (11.46 KB, text/plain)
2007-08-17 11:18 EDT, Traxtopel
no flags Details
x30-lspci (3.63 KB, text/plain)
2007-08-17 11:19 EDT, Traxtopel
no flags Details
x40-dmidecode (12.97 KB, text/plain)
2007-08-17 11:19 EDT, Traxtopel
no flags Details
x40-lspci (4.01 KB, text/plain)
2007-08-17 11:20 EDT, Traxtopel
no flags Details
x41-dmidecode (12.98 KB, text/plain)
2007-08-17 11:20 EDT, Traxtopel
no flags Details
x41-lspci (4.58 KB, text/plain)
2007-08-17 11:20 EDT, Traxtopel
no flags Details
t43-dmidecode (12.89 KB, text/plain)
2007-08-17 12:02 EDT, Traxtopel
no flags Details
t43-lspci (5.38 KB, text/plain)
2007-08-17 12:03 EDT, Traxtopel
no flags Details
IBM Thinkpad quirks (5.64 KB, application/octet-stream)
2007-08-17 12:03 EDT, Traxtopel
no flags Details
Lenovo Thinkpad quirks (2.37 KB, application/octet-stream)
2007-08-17 12:04 EDT, Traxtopel
no flags Details
t60-dmidecode (12.87 KB, text/plain)
2007-08-17 16:09 EDT, Traxtopel
no flags Details
t60-lspci (6.63 KB, text/plain)
2007-08-17 16:09 EDT, Traxtopel
no flags Details
x60-dmidecode (12.93 KB, text/plain)
2007-08-17 16:10 EDT, Traxtopel
no flags Details
x60-lspci (7.05 KB, text/plain)
2007-08-17 16:10 EDT, Traxtopel
no flags Details

  None (edit)
Description Traxtopel 2007-08-09 09:39:52 EDT
Description of problem:
I am running RHEL5 U1 beta (2.6.18-38.el5), on a IBM Thinkpad T42 (model 2373) 

it will suspend/resume using the following quirks
--quirk-s3-bios --quirk-s3-mode

I also added the following

      <!-- T42 -->
      <match key="system.hardware.product" prefix="2373">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>

I also added the following which is probably specific to my environment.
/etc/pm/config.d/unload_modules
SUSPEND_MODULES="nvidia fglrx ipw3945 iwl3945 hsfmc97ich hsfserial hsfengine
hsfsoar hsfosspec"


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Traxtopel 2007-08-10 15:36:25 EDT
Created attachment 161073 [details]
2373 dmidecode
Comment 2 Traxtopel 2007-08-10 15:36:50 EDT
Created attachment 161074 [details]
2373 lspci
Comment 3 Traxtopel 2007-08-14 12:18:38 EDT
Created attachment 161281 [details]
t30-2366-dmidecode
Comment 4 Traxtopel 2007-08-14 12:18:58 EDT
Created attachment 161282 [details]
t30-2366-lspci
Comment 5 Traxtopel 2007-08-14 12:20:08 EDT
Created quirk for an IBM Thinkpad T30 2366
      <!-- T30 -->
      <match key="system.hardware.product" prefix="2366">
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
        <merge key="power_management.quirk.dpms_suspend" type="bool">true</merge>
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>
Comment 6 Traxtopel 2007-08-15 14:23:40 EDT
Created attachment 161390 [details]
a31p-dmidecode
Comment 7 Traxtopel 2007-08-15 14:24:02 EDT
Created attachment 161391 [details]
a31p-lspci
Comment 8 Traxtopel 2007-08-15 14:24:55 EDT
Created quirk for an IBM Thinkpad A31P 2653
      <!-- A31P -->
      <match key="system.hardware.product" prefix="2653">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>
Comment 9 Traxtopel 2007-08-15 20:41:09 EDT
Created attachment 161418 [details]
t23-dmidecode
Comment 10 Traxtopel 2007-08-15 20:41:31 EDT
Created attachment 161419 [details]
t23-lspci
Comment 11 Traxtopel 2007-08-15 20:42:40 EDT
      <!-- T23 -->
      <match key="system.hardware.product" prefix="2647">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>
Comment 12 Traxtopel 2007-08-15 20:43:37 EDT
Created attachment 161420 [details]
x30-dmidecode
Comment 13 Traxtopel 2007-08-15 20:44:13 EDT
Created attachment 161421 [details]
x30-lspci
Comment 14 Traxtopel 2007-08-15 20:44:58 EDT
      <!-- X40/X30 -->
      <match key="system.hardware.product" prefix="2672">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
      </match>
Comment 15 Traxtopel 2007-08-15 20:45:33 EDT
Created attachment 161422 [details]
t60p-dmidecode
Comment 16 Traxtopel 2007-08-15 20:45:52 EDT
Created attachment 161423 [details]
t60p-lspci
Comment 17 Traxtopel 2007-08-15 20:47:13 EDT
      <!-- T60p -->
      <match key="system.hardware.product" prefix="2007">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>
Comment 18 Traxtopel 2007-08-17 11:18:41 EDT
Created attachment 161739 [details]
x30-dmidecode
Comment 19 Traxtopel 2007-08-17 11:19:10 EDT
Created attachment 161740 [details]
x30-lspci
Comment 20 Traxtopel 2007-08-17 11:19:48 EDT
Created attachment 161741 [details]
x40-dmidecode
Comment 21 Traxtopel 2007-08-17 11:20:09 EDT
Created attachment 161742 [details]
x40-lspci
Comment 22 Traxtopel 2007-08-17 11:20:28 EDT
Created attachment 161743 [details]
x41-dmidecode
Comment 23 Traxtopel 2007-08-17 11:20:51 EDT
Created attachment 161744 [details]
x41-lspci
Comment 24 Traxtopel 2007-08-17 12:02:56 EDT
Created attachment 161746 [details]
t43-dmidecode
Comment 25 Traxtopel 2007-08-17 12:03:15 EDT
Created attachment 161747 [details]
t43-lspci
Comment 26 Traxtopel 2007-08-17 12:03:49 EDT
Created attachment 161748 [details]
IBM Thinkpad quirks
Comment 27 Traxtopel 2007-08-17 12:04:17 EDT
Created attachment 161749 [details]
Lenovo Thinkpad quirks
Comment 28 Traxtopel 2007-08-17 12:09:09 EDT
Not finished yet, still have the following machines to test(perhaps more).
R50 1830 BU3
R50 1836 3UU
R52 1858 4MU
T60 1951 A31
T30 2356 91U
X40 2382 8WU
X41 2525 AK5
A31 2625 JEU
A31 2652 J5U
R31 2656 E6U
R40 2681 DBU
R40 2682 K4U
R51 2883 2QU
Comment 29 Traxtopel 2007-08-17 16:09:19 EDT
Created attachment 161765 [details]
t60-dmidecode
Comment 30 Traxtopel 2007-08-17 16:09:44 EDT
Created attachment 161766 [details]
t60-lspci
Comment 31 Traxtopel 2007-08-17 16:10:05 EDT
Created attachment 161767 [details]
x60-dmidecode
Comment 32 Traxtopel 2007-08-17 16:10:32 EDT
Created attachment 161768 [details]
x60-lspci
Comment 34 David Zeuthen 2007-08-22 11:51:52 EDT
This is now in 0.5.8.1-24.el5.
Comment 36 Dennis Gregorovic 2007-09-20 22:55:45 EDT
Moving back to modified as RHBA-2007:0870-02 was dropped_no_ship.  This bug
needs to be attached to RHBA-2007:0632-03
Comment 38 Cameron Meadors 2007-09-25 14:43:23 EDT
Verified that the files were added.  Cannot test the functionality of all the
quirks because we lack the specific hardware.
Comment 40 errata-xmlrpc 2007-11-07 13:01:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0632.html

Note You need to log in before you can comment on or make changes to this bug.