Bug 2515 - glibc breaks several applications
glibc breaks several applications
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-03 14:57 EDT by Thomas Zehetbauer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-16 11:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 1999-05-03 14:57:02 EDT
the new glibc-2.1 breaks source compatibility with
xterm(patch98) and SSH-2.1.26.

Also there is a binary compatibility problem with
blackdown4s JDK which can be worked around by using either
native_threads(get glibc native package and "export
THREADS_FLAG=native") or probably the libc5 version.
Comment 1 Nalin Dahyabhai 1999-05-10 14:03:59 EDT
I seem to have read somewhere that undefining HAVE_UTMPX_H in the
offending source for ssh fixes the problem, but I haven't tested that.
Comment 2 Jeff Johnson 1999-05-16 11:59:59 EDT
The fix for ssh-1.2.26 is add -D_GNU_SOURCE to CFLAGS, compile
and delete the bogus line that the compile fails on. (The line
is already deleted in ssh-1.2.27).

I'm closing this bug because
   a) xterm(patch98) is part of XFree86 (I assume).
   b) ssh is not a Red Hat package and the fixes are available.
   c) the broken blackdown JDK is already mentioned in several
   other bug reports and will be solved there not here.

Note You need to log in before you can comment on or make changes to this bug.