Bug 251568 - nfsd started in runlevel 2, but not rpcbind
Summary: nfsd started in runlevel 2, but not rpcbind
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-09 19:41 UTC by Thomas Schweikle
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.1.4-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 19:02:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Schweikle 2007-08-09 19:41:32 UTC
Description of problem:
in runlevel 2 nfsd gets started, but not rpcbind (at least):
# chkconfig --list | grep 'nfs\|rpc'
nfs             0:Aus   1:Aus   2:Ein   3:Ein   4:Ein   5:Ein   6:Aus
nfslock         0:Aus   1:Aus   2:Aus   3:Ein   4:Ein   5:Ein   6:Aus
rpcbind         0:Aus   1:Aus   2:Aus   3:Ein   4:Ein   5:Ein   6:Aus
rpcgssd         0:Aus   1:Aus   2:Aus   3:Ein   4:Ein   5:Ein   6:Aus
rpcidmapd       0:Aus   1:Aus   2:Aus   3:Ein   4:Ein   5:Ein   6:Aus
rpcsvcgssd      0:Aus   1:Aus   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus


Version-Release number of selected component (if applicable):
rpcbind-0.1.4-6.fc7
nfs-utils-lib-1.0.8-10.fc7
system-config-nfs-1.3.25-1.fc7
nfs-utils-1.1.0-1.fc7

How reproducible:
Install Fedora 7 on a clean new system, upgrade to Fedora 7, ...

Steps to Reproduce:
1. Install Fedora 7
2. Install nfs
3. Start runlevel 2

  
Actual results:
Fedora will try to start nfsd, but since rpcbind is not running this fails


Expected results:
Two solutions:
If nfs is intedned to start in runnlevel 2, rpcbind and related tools should be
started too.

If nfs is not intended to start in runnlevel 2, nfs should not be started (I'd
supose this was the intended version).

Additional info:

Comment 1 Steve Dickson 2007-09-14 19:23:55 UTC
Fixed in rpcbind-0.1.4-8.fc7

Comment 2 Fedora Update System 2007-09-18 22:31:03 UTC
rpcbind-0.1.4-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Thomas Schweikle 2007-09-23 18:28:55 UTC
Seems fixed if installed activating testing.

Comment 4 Fedora Update System 2007-10-29 19:02:12 UTC
rpcbind-0.1.4-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.