Bug 25166 - wrong NIC detected, causing booting to freeze
wrong NIC detected, causing booting to freeze
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-28 20:50 EST by Vincent
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 15:21:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent 2001-01-28 20:50:55 EST
I have a NIC that contains a DEC 21041 chip and I use a floppy and 
downloaded RPMs to install.
The installation program of Redhat 7.0 selected some other NIC by DEC.  
During the bootup, the kernel froze when it tried to load the wrong module. 
 I have to use the install disk to boot, delete the "modules.conf", then I 
can boot.  I demand that I will get to choose the NIC card during an 
"EXPERT" install, damn it.  There's no way the installation program can get 
everything right.  I should be allow to set the components in my PC during 
the installation.  Even Windoze allows me to select the hardware components 
I have install.
I almost give up installing Redhat 7 because of this.  It took me a long 
time to fix this.  I was able to do it because I'm an experience Linux 
user, but the average joe will simply give up.
Please, give users the option to choose the hardware components, at least 
in the "expert" installation mode.  Why the hell you call it expert mode if 
I don't even get to choose the hardware components?
Comment 1 Erik Troan 2001-01-30 17:44:27 EST
When I boot into expert mode from a 7.0 CD, I get:

	do you have a driver disk (say no)
	where are you installing from (Local CDROM)
	do you have anymore devices to add (yes)
	what kind of device (network)

and it all works fine for me. Can you tell me where the sequence you see differs
(I left out some random language and keyboard questions)

Comment 2 Vincent 2001-02-01 01:12:07 EST
I used a boot floppy plus RPMs stored on a fat32 partition.  I chose "expert 
mode during the boot.  When I was asked "where are you installing from", I chose 
"Local Disk".  I don't remember being ask "do you have anymore devices to add".
Comment 3 Erik Troan 2001-02-01 12:56:09 EST
I hate to ask this, but is there any way for you to try again?
Comment 4 Vincent 2001-02-01 15:03:42 EST
i can try it again in a few days.  I have to download all the rpm again though.
Comment 5 Vincent 2001-02-08 01:33:34 EST
ok, you can close this bug report now.  In the "expert" mode, after I selected 
"install from local harddrive" and specified the location of the base and rpm 
directory, I was presented a screen that said "I have found the following device 
on your system\n Adaptec 2940...\n" with two buttons: "Done" and "Add Device".  
After I selected "Add device", I was presented with a screen which I get to 
choose between scsi devices and network devices.
Just a suggestion, move the network device selection to another section 
seperate from the selection of rpm location.  The current process is confusing.

I want to open another bug report.  If I don't select expert installation, the 
installation program will hang after I specify the location of the installation 
source.  The installation program did detected my Adaptec 2940UW card correctly 
and it detected my partitions correctly too.

Note You need to log in before you can comment on or make changes to this bug.