Bug 251687 - xorg-x11-xinit-1.0.2-16.fc6: fails to start (typo?)
xorg-x11-xinit-1.0.2-16.fc6: fails to start (typo?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
6
i386 Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 08:34 EDT by Vince Schiavoni
Modified: 2014-06-18 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 19:22:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vince Schiavoni 2007-08-10 08:34:06 EDT
Description of problem:
xorg-x11-xinit-1.0.2-16.fc6 installed yesterday; ~/.xsession-errors file stopped
growing (which would ordinarily be a good thing...); I found in my
~/.xsession-errors-:0 the following single line: "/etc/X11/xinit/Xsession: line
15: unask: command not found".  This appears to be a typo for "umask" in line 15
of /etc/X11/xinit/Xsession:
"    if ( unask 077 && cp /dev/null "$errfile" 2> /dev/null ); then"
I fixed it, and ran "sh /etc/X11/xinit/Xsession", but no change - maybe I have
to reboot/restart X???

Version-Release number of selected component (if applicable):
xorg-x11-xinit-1.0.2-16.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade/install xorg-x11-xinit-1.0.2-16.fc6;
2. Observe meltdown.
3.
  
Actual results:
Script failed as noted.

Expected results:
Script succeeds/ ~/.xsession-errors grows to alarming proportions with the usual
error messages.

Additional info:
uname -a: Linux presario.localdomain 2.6.22.1-32.fc6 #1 SMP Wed Aug 1 15:15:33
EDT 2007 i686 athlon i386 GNU/Linux
Smolt Profile:
http://smolt.fedoraproject.org/show?UUID=02d04cb7-5a0e-4b31-8f1f-7be6f2d85507
Comment 1 Vince Schiavoni 2007-08-10 08:44:23 EDT
I just found this, must have missed it somehow on my first search: Bug #250882.
Comment 2 Søren Sandmann Pedersen 2007-08-10 18:54:50 EDT
If you do change it to 'umask', does it work then?
Comment 3 Vince Schiavoni 2007-08-10 19:22:07 EDT
I already changed "unask" to "umask" as noted above, '... and ran "sh
/etc/X11/xinit/Xsession", but no change - maybe I have to reboot/restart X...'.
 So I ended the session, restarted X at the login screen, logged back in, and
now I'm once again receiving copious amounts of warnings, errors, and other
chatter in ~/.xsession-errors.  So I guess the answer to your question is: Yes,
if I then also restart X.

Thanx and Regards,
Vince Schiavoni
Comment 4 Matěj Cepl 2007-12-10 04:23:46 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 5 Vince Schiavoni 2007-12-12 19:22:44 EST
To the best of my knowledge, this is already fixed/doesn't exist in F7, since my
other two machines never showed this problem (they're both already upgraded to
F7).  Besides, it was a simple typo and I long since fixed it myself.

Thanx and Regards,
VJS

Note You need to log in before you can comment on or make changes to this bug.