Bug 251719 - zfcpconf.sh should support 3 fields in zfcp.conf
zfcpconf.sh should support 3 fields in zfcp.conf
Status: CLOSED DUPLICATE of bug 236016
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils (Show other bugs)
s390x Linux
high Severity high
: ---
: ---
Assigned To: Phil Knirsch
Depends On:
  Show dependency treegraph
Reported: 2007-08-10 13:03 EDT by Brad Hinson
Modified: 2015-03-04 20:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-15 17:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
zfcpconf.sh support for 3 or 5 values in /etc/zfcp.conf. Warn if using 5. (1.34 KB, patch)
2007-08-10 14:42 EDT, Brad Hinson
no flags Details | Diff

  None (edit)
Description Brad Hinson 2007-08-10 13:03:29 EDT
Description of problem:
When installing to zFCP devices, anaconda now writes 3 fields to /etc/zfcp.conf 
- device number
This is because the fields for SCSI ID and SCSI LUN are obsolete and no longer
required.  zfcpconf.sh needs to be updated to read in 3 fields instead of
expecting 5.  Otherwise, the FCP LUN is substituted for the WWPN when bringing
the device online.

Version-Release number of selected component (if applicable):

How reproducible:
Install using zFCP so that anaconda creates /etc/zfcp.conf.
Comment 2 Brad Hinson 2007-08-10 14:42:40 EDT
Created attachment 161070 [details]
zfcpconf.sh support for 3 or 5 values in /etc/zfcp.conf.  Warn if using 5.
Comment 3 RHEL Product and Program Management 2007-12-03 15:45:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Phil Knirsch 2008-01-21 08:35:03 EST
Great fix, flagging for RHEL-5.3 and giving Devel ACK.

Read ya, Phil
Comment 5 Brad Hinson 2008-02-15 17:11:27 EST

*** This bug has been marked as a duplicate of 236016 ***

Note You need to log in before you can comment on or make changes to this bug.