Bug 251722 - Unable to set an alias via XML-RPC interface
Summary: Unable to set an alias via XML-RPC interface
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs   
(Show other bugs)
Version: 2.18
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-10 18:09 UTC by Lubomir Kundrak
Modified: 2013-06-24 02:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 11:09:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lubomir Kundrak 2007-08-10 18:09:44 UTC
Description of problem:

One of our tools would need to file bugs in bugzilla and set an alias (that is
known a the time of bug creation and never changes). Looking at the POD
documentation this doesn't seem to be possible.

I've tried to add 'alias' argument to the bugzilla.createBug call, but it did
not have any effect.

Additional info:

As creating or changing aliases is not a documented at all, this is certainly
not a bug. Could you please consider this to be a feature request for a feature
that would be really useful?

Comment 1 Noura El hawary 2007-08-17 05:20:41 UTC
HI Lubomir,

We have just added this feature to bugzilla.

You should be able now to set an alias via XML-RPC interface when you create a
new bug using 'alias' as a key in the data hash argument that you pass to the
bugzilla.createBug() functions ,, also if you look at the POD documentation you
should fine some explanation there as well :)

Noura

Comment 2 Lubomir Kundrak 2007-08-17 09:17:21 UTC
Noura: Thanks, this works perfectly for me. You can close this bug report.


Note You need to log in before you can comment on or make changes to this bug.