Bug 251726 - mediacheck does not work
mediacheck does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 14:21 EDT by Till Maas
Modified: 2013-01-09 23:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 11:39:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-08-10 14:21:54 EDT
Description of problem:

There seems to be some procedure to force a mediacheck for installation mediums,
maybe
vmlinuz initrd=initrd.img ide=nodma mediacheck

(I do not know, because I never used it and it does not work in qemu or
VirtualBox and the release notes mentioned two different commandlines).

Can you please add the correct commandline to the boot menu, so it can be easily
selected? The release notes recommend using it, so imho it should be easier to use.
Comment 1 Till Maas 2007-08-10 14:33:11 EDT
Ah, I just remembered that Anaconda asks every time whether or not the
installation medium should be checked, so it is only a problem of wrong release
notes. I will file a new bug report for this in the Documentation Product.
Comment 2 Till Maas 2007-08-10 14:39:28 EDT
Sorry, I am not sure, whether this is a mediacheck problem or a problem because
VirtualBox does not find the DVD, but the f8-test1 anaconda does not ask me,
whether or not I want to check the medium. The F7 installer differs here, but it
seems to load the piix_ata driver or something. The f8-test1 installer seems not
to do this.

So if it normally asks whether or not to check the medium, I guess this bug can
be closed, and it may be another bug.
Comment 3 Jesse Keating 2007-08-10 18:35:53 EDT
Yes, installer always asks, if it can find a media to check.  If it can't find
the DVD, it's not going to ask you to check it.
Comment 4 Jeremy Katz 2007-08-13 11:39:53 EDT
What Jesse said :-)

If VirtualBox isn't finding the DVD, it's probably a bug in its IDE emulation
(as iirc, it's based on older qemu and older qemu had really buggy IDE emulation
that doesn't work with the new libata-based pata drivers)

Note You need to log in before you can comment on or make changes to this bug.