Bug 251730 - [EMC 4.7 bug] Exception was occurred during RHEL4.5 SAN boot installation with VCM on Symmetrix
Summary: [EMC 4.7 bug] Exception was occurred during RHEL4.5 SAN boot installation wit...
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted   
(Show other bugs)
Version: 4.7
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks: 241692 246627 367631
TreeView+ depends on / blocked
 
Reported: 2007-08-10 18:31 UTC by Pan Haifeng
Modified: 2009-06-20 00:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 14:21:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo1 (354.43 KB, image/pjpeg)
2007-08-20 15:32 UTC, Pan Haifeng
no flags Details
photo2 (341.40 KB, image/pjpeg)
2007-08-20 15:32 UTC, Pan Haifeng
no flags Details
photo3 (361.82 KB, image/pjpeg)
2007-08-20 15:33 UTC, Pan Haifeng
no flags Details

Description Pan Haifeng 2007-08-10 18:31:15 UTC
Description of problem:
Exception was occurred when they create mirror of system volume during RHEL4.5 
installing. 


Version-Release number of selected component (if applicable):


How reproducible:
The procedure is as follows. 

1) Create ks.cfg

2) boot from another OS then put ks.cfg on SAS disk

3) boot from CD-ROM. execute linux ks=hd:sda1/ks.cfg at "ELILO Boot:" prompt.

4) error was occurred during making partition by using Disk Druid

 

<Configuration>
  +-----------------------------------+ PRIMEQUEST520
  | PRIMEQUEST520                     |   PAL : 7.46/9.08
  |                                |   SAL : 2.23/2.23
  | SAS x1 (/dev/sda for ks.cfg)         |   BMC : 1.27
  |                                |   EFI : 1.10.1.13
  |                                |   MMB : 3.13
  |   IOU#0-slot#4      IOU#0-slot#6    |
  |     LP11002          LP11002      | LP11002
  |    port0  port1     port0   port1   |   Firm : 2.70a5
  +-----------------------------------+   EFI  : 3.11X1
        |       |    |     |
        |      n/a   n/a   n/a
        |port0
  +-----------------------+
  |   FUJITSU SN200/M430  | FabricOS: v5.1.0b
  +-----------------------+
        |port4  
        |
  +--------------------------+
  |    FA04-c0           | Group6 RAID Configuration
  |    Group6(256LUN)      |  LUN#000-001(30GB) : M1/M2
  |                     |  LUN#002-123( 2GB) : 7+1 RAID5
  |  DMX3(HK190100302)      |  LUN#124-247( 2GB) : M1/M2,BCV
  |  Micro. Rev: 5771.95.103 |  LUN#248-249( 2GB) : 7+1 RAID5
  +--------------------------+  LUN#250-255       : GateKeeper

 



Steps to Reproduce:
1.
2.
3.
  
Actual results:
An unhandled exception has occured. This is most likely a 
bug. Please copy the full text of this exception and file a detailed bug report 
against anaconda at 
http://bugzilla.redhat.com/bugzilla 

Traceback(most recent call last): 
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/gui.py", line 792 in next 
Clicked 
self.setScreen() 
---- 
---- 
---- 
ZeroDivisionError: fload division 



Expected results:
No error

Additional info:
Exception was not occurred without GateKeeper(GK) LUN, but was occurred with GK
(256 LUNs and 60 LUNs). 

The error of RHEL4.5 seems to happen when there is a very small size volume 
like GK. 



reproduce this without creating ks.cfg and could reproduce.
Error was also occurred during making partition by using Disk Druid.

According to the analysis of Fujitsu, it seems to be caused by totalsector value
(= 0) of GK.

Comment 2 David Cantrell 2007-08-20 15:22:24 UTC
Please attach the full anaconda traceback log to this bug report.

Comment 3 Pan Haifeng 2007-08-20 15:32:30 UTC
Created attachment 161891 [details]
photo1

Comment 4 Pan Haifeng 2007-08-20 15:32:58 UTC
Created attachment 161892 [details]
photo2

Comment 5 Pan Haifeng 2007-08-20 15:33:42 UTC
Created attachment 161893 [details]
photo3

Comment 6 Pan Haifeng 2007-08-20 15:34:43 UTC
upload three photoes with the error message. Is that good to replace the full 
anaconda traceback log?

Comment 7 David Cantrell 2007-08-20 16:16:29 UTC
The photos are sufficient for now.

Comment 8 David Cantrell 2007-08-23 17:22:03 UTC
No time to work on this issue for 4.6, moving it to 4.7 proposed.

Comment 10 RHEL Product and Program Management 2007-11-29 04:00:27 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 Andrius Benokraitis 2008-02-15 14:13:17 UTC
Haifeng/Wayne - is it possible for us to connect remotely to a Symmetrix since
we don't have one in house?

Comment 14 David Cantrell 2008-03-25 20:59:10 UTC
Any update on this?

Comment 15 Wayne Berthiaume 2008-03-26 12:48:13 UTC
Hi Andrius.

   Unfortunately, we don't have the ability to provide remote access to a Symm 
in our lab.

Regards,
Wayne.

Comment 18 Andrius Benokraitis 2008-03-28 14:21:09 UTC
Hi Wayne, we really look to be in a bind here - with no means to the hardware,
our developer (David Cantrell) can't develop a fix. I think I have no choice but
to close this until we can get the hardware or get remote access to one in the
future.


Note You need to log in before you can comment on or make changes to this bug.