Bug 251744 - Thousands of "ACPI Error (evgpe-0711)..." when external display device is connected to SVGA out port
Thousands of "ACPI Error (evgpe-0711)..." when external display device is con...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-08-10 16:00 EDT by David Shrader
Modified: 2008-03-26 13:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch: disable stray GPE properly (701 bytes, patch)
2008-03-06 21:49 EST, Zhang Rui
no flags Details | Diff

  None (edit)
Description David Shrader 2007-08-10 16:00:25 EDT
Description of problem:

Whenever I plug in an external display device to my SVGA out port, the CPU usage
jumps to 100% and stays there until the device is removed.  What type does not
matter, as I have tried with an LCD monitor and two projectors, each giving me
the same result.  After much searching, I found several ACPI error messages in
/var/log/messages corresponding to the times when the devices were plugged in. 
I tested again by plugging in an external monitor, and checking
/var/log/messages again.  The same errors where there for that time period that
the device was plugged in.  This is what eats up my CPU: syslogd writing these
error messages that are thrown hundreds of times per second.  This is what
/var/log/messages looks like just after I plug in the device:

Aug 10 10:14:01 raiyuu kernel: ACPI Error (evgpe-0711): No handler or method for
GPE[17], disabling event [20060707]
Aug 10 10:14:01 raiyuu last message repeated 91 times
Aug 10 10:14:01 raiyuu kernel: <4): ): No handler or method for GPE[17]): No
handler or method for): No handler or method for ): No handler or method for G):
No handler or method f): No handler or method for): No handler or method for G):
No handler or method for): No handler or method for G): No handler or method for
): No handler or method for G): No handler or method for GP): No handler or
method for): No handler or method for GPE[17): No handler or method for G): No
handler or method fo): No handler or method for): No handler or method for GP):
No handler or method for): No handler or method fo): No handler or method for
G): No handler or method for ): No handler or method for G): No handler or
method for G): No handler or method for GP): No handler or method fo): No
handler or method for G): No handler or method for GP): No handler or method for
G): No handler or method for): No handler or method for G): No handler or method
for GP): No handler or method for GPE[): No handler or method for GPE[17], d): No 
Aug 10 10:14:01 raiyuu kernel: ler or method for GPE[17]): No handler or method
for G): No handler or method for ): ...

These messages continue for several hundred lines in the file.  They stop at the
time when I disconnected whatever was attached to the SVGA out port.

I did find out that if I start Fedora with acpi off, I do not get this problem.
 I can connect an external display device to the SVGA out port with no problems
if I boot without acpi.  I can enable the external display device in the NVIDIA
settings, and view it just fine.  These errors don't show up in
/var/log/messages for the duration of the boot without acpi.

Version-Release number of selected component (if applicable):
Hope this is what you need:
[david@raiyuu log]$ rpm -qa | grep acpi
acpid-1.0.4-5

How reproducible:
On my computer, absolutely.  All I have to do is plug in something to the SVGA
out port.

Steps to Reproduce:
1. Plug in a device to my SVGA out port.

Actual results:
CPU at 100%, hard disk light constantly blinking

Expected results:
CPU to stay near 0

Additional info:
This computer is a PowerPro laptop approximately two years old.  I had this
problem in Fedora Core 5, but updated to Fedora Core 6, hoping to remove the
problem.  I have not tried to trouble-shoot it in several months.  I'm not sure
what to give you other than the output to lspci:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 04)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce Go 6600]
(rev a2)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit
Ethernet (rev 10)
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)
06:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:09.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host
Controller
06:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia
Controller

I'm sure that this problem is hardware specific, so reproducing on another
machine will probably be hard.  Just let me know what you need from me, and I
will happily get it done!

Thank you for your time!
David
Comment 1 Jon Stanley 2008-01-07 20:50:42 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 2 David Shrader 2008-01-09 12:51:37 EST
Unfortunately, Fedora is not currently installed on the computr at this time.  
I have a new computer that I use Fedora 8 on right now, and my wife uses the 
computer in question.

I am more than willing to try Fedora 8 on this laptop.  If I use the Live CD, 
will this provide a suitable testing environment?  Meaning, if I boot the 
laptop with the Live CD and plug in an external monitor, would the results of 
this be the same as if I had installed Fedora 8 to the hard drive?  I'm just 
worried about installing Fedora 8 to the hard drive as it won't be permanent, 
and I'm not sure how to take care of the boot sequence if I remove the Fedora 
partitions (my wife is not ok with me wiping the computer and putting her stuff 
back on later right now!).

So, if the LiveCD will provide adequate testing, I can easily do that.
Thank you,
David
Comment 3 David Shrader 2008-03-06 18:58:59 EST
This bug still exists in Fedora 8.  Whenever an external video output device is
connected to the SVGA port, I still get the same errors:

[root@localhost david]# tail /var/log/messages
Mar  6 17:48:00 localhost kernel: <): No handler or method for GPE[17],
disabling event [200701): No handler or method for GPE[17], disabling event
[200701): No handler or method for GPE[17], disabling e): No handler or method
for GPE[17], disabling event): No handler or method for GPE[17], disabling event
[20070126]): No handler or method for GPE[17], disabling): No handler or method
for GPE[17], disabling eve): No handler or method for GPE[17], disabling eve):
No handler or method for GPE[17], disabling): No handler or method for GPE[17],
disabling event [20): No handler or method for GPE[17], disabling event ): No
handler or method for GPE[17], disabling event [20070126]
Mar  6 17:48:00 localhost kernel: ): No handler

I have changed the status of this bug to urgent because the user of this laptop
doesn't want to use Linux.  I only have a limited amount of time to troubleshoot
Fedora.  If you don't feel that this type of bug warrants immediate action, and
there are more pressing issues, please let me know, and I will close the bug report.

Thank you,
David
Comment 4 Chuck Ebbert 2008-03-06 19:36:15 EST
Have you made sure you have the latest BIOS update installed?
Comment 5 Zhang Rui 2008-03-06 21:49:09 EST
Created attachment 297134 [details]
patch: disable stray GPE properly

Please apply this patch to 2.6.25-rc kernel and see if it helps. :)
Comment 6 David Shrader 2008-03-07 14:28:20 EST
My BIOS is updated (at least as far as I am able to find!).

I've currently got kernel 2.6.24.3, which seems to be the limit of yum.

Does this mean you would like me to install 2.6.25-rc and see if that works?  If
it doesn't, patch it, and try again?

Now, I've never installed a kernel manually, but am more than willing to do it.
 I have found the following:

http://fedoraproject.org/wiki/Docs/CustomKernel

I imagine the process is similar except that I won't have an rpm of the source.
   How do I get the 2.6.25-rc kernel source (I've looked on www.kernel.org, but
am not sure how to use the files there)?

Thanks,
David
Comment 7 Dave Jones 2008-03-07 14:53:22 EST
The easiest way would be to skip all the rpm stuff and just build/install a
kernel by hand.
quick howto:

as root:
$ yum install git

then as user:
$ git clone git://www.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
$ cd linux-2.6
(Save the patch in comment 5 as 'gpe.patch' in this dir)
$ cat gpe.patch | patch -p1

$ wget http://www.codemonkey.org.uk/junk/kernel-2.6.25-i686.config
(this is a config from rawhide that I just generated)
$ mv kernel-2.6.25-i686.config .config
$ make oldconfig
$ make bzImage
$ make modules
$ su -
(become root)
$ make modules_install
$ make install

And now you should see a new option in grub when you reboot.

I think that should be all you need.
Comment 8 David Shrader 2008-03-07 15:30:12 EST
I had a problem with the git clone command.  It told me the connection was
refused.  I tried replacing git:// with http://, and it is now downloading.  Is
this correct, or did I somehow mess up the original command and am now getting
stuff I don't need?

Thanks,
David
Comment 9 Dave Jones 2008-03-07 15:47:27 EST
ah yes. my bad.
http is fine.

I meant to type
git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git  but
http://www.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git will get
you exactly the same bits but over a different transport.
Comment 10 David Shrader 2008-03-07 16:56:57 EST
I got the new kernel installed (hopefully correctly), and the patch worked.  I
can now plug in an external monitor with acpi enabled and not have those error
messages being thrown.

Thank you all for the help!  I learned a lot.

Let me know if you need any other information from me, and I'll gladly get it to
you.  Do I close the report or will who the report is assigned to take care of
all those details?

Thanks again!  You all are great!
David
Comment 11 Dave Jones 2008-03-07 17:05:37 EST
Thanks for your help in debugging this.  We'll get it into an official Fedora
update kernel soon.  Hopefully Intel will get this upstream soon too.
Comment 12 Zhang Rui 2008-03-09 21:38:46 EDT
Bob,
The patch to fix the stray GPE problem which is already upstream now doesn't 
work.
We still need the incremental patch in comment #5.
Comment 13 Chuck Ebbert 2008-03-10 14:52:41 EDT
Fixed in 2.6.24.3-24.fc8
Comment 14 Len Brown 2008-03-11 01:10:01 EDT
patch in comment #5 applied to upstream acpi tree
Comment 15 Chuck Ebbert 2008-03-12 14:51:36 EDT
(In reply to comment #14)
> patch in comment #5 applied to upstream acpi tree

That patch causes problems for other users. See bug 436959.
Comment 16 Chuck Ebbert 2008-03-19 12:22:55 EDT
Looks like we also need commit a7f9b1f24974da287771e2d70b30d9ca7bd66684 before
this fix will work.
Comment 17 Chuck Ebbert 2008-03-19 12:24:23 EDT
(a7f9b1f24974da287771e2d70b30d9ca7bd66684 is needed in 2.6.24)
Comment 18 Chuck Ebbert 2008-03-19 12:42:34 EDT
commit a7f9b1f24974da287771e2d70b30d9ca7bd66684 plus the patch from comment #5
added to kernel 2.6.24.3-46
Comment 19 Zhang Rui 2008-03-19 21:44:15 EDT
David Shrader , can you confirm that the new kernel work for you?
Comment 20 Chuck Ebbert 2008-03-20 19:42:43 EDT
We have confirmed that with both patches applied battery status is still okay,
anyway.
Comment 21 Fedora Update System 2008-03-20 23:15:15 EDT
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8
Comment 22 Fedora Update System 2008-03-21 18:16:32 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630
Comment 23 Fedora Update System 2008-03-26 13:14:43 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.