Bug 251755 - Error with udev rules for scsi tape drive
Summary: Error with udev rules for scsi tape drive
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-10 21:08 UTC by Bruno Wolff III
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 113-12.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 22:12:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2007-08-10 21:08:26 UTC
Description of problem:
Recently I started seeing a udev error message during boot referring to a scsi
tape device. This happens on two different computers. On one that also has a
ups, the ups isn't recognized by nut (service ups) during the boot, but
unplugging and replugging the ups usb cable and restarting the service fixes it.
I don't know if that problem is related, but it started happening about the same
time as I noticed the error message about the scsi tape device.
I don't have the exact error message as i can't find it in any log files and it
scrolls off the screen before I can do anything to copy it.

Version-Release number of selected component (if applicable):
udev-113-9.fc7

How reproducible:
It seems to happen every reboot.

Steps to Reproduce:
1. Reboot a machine with a scsi tape drive and watch the messages.
2.
3.
  
Actual results:
Unexpected error message.

Expected results:
No unexpected error message.

Additional info:

Comment 1 Harald Hoyer 2007-08-11 11:54:18 UTC
what does the error message say?

Comment 2 Harald Hoyer 2007-08-11 11:55:19 UTC
The Screen-Lock-Key is your friend :-)

Comment 3 Bruno Wolff III 2007-08-11 14:33:28 UTC
Thanks, I didn't know that you could pause the screen during boot.
The error message is (warning: copied by hand):
Starting udev: udev-event[1141]: node_symlink: symlink(../../nst0,
/dev/tape/by-id/scsi--nst.udev-tmp) failed: Not a directory

Comment 4 260795 2007-08-20 07:36:35 UTC
I have the same problem here. It looks like a link from /dev/tape to nst0, as
needed for example by mt, is first created and then of course a /dev/tape/
directory can't exist. I tried manually deleting the /dev/tape link just to see
what happens, but it simply gets recreated again.

Comment 5 Fedora Update System 2007-08-27 21:41:01 UTC
udev-113-12.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Bruno Wolff III 2007-08-27 22:36:26 UTC
I tested udev-113-12.fc7 and I no longer get a warning message while udev is
starting.

Comment 7 Fedora Update System 2007-09-04 22:12:29 UTC
udev-113-12.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.