Bug 251809 - wireless-tools kvetches about wireless extensions after kernel 2.6.22.1-32.fc6 upgrade
Summary: wireless-tools kvetches about wireless extensions after kernel 2.6.22.1-32.fc...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: wireless-tools   
(Show other bugs)
Version: 6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-11 16:10 UTC by nathan r. hruby
Modified: 2007-12-27 23:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 23:41:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nathan r. hruby 2007-08-11 16:10:55 UTC
Description of problem:
Latest fc6 kernel (2.6.22) includes wireless extensions v22, seemingly this
causes wireless-tools-28 to be fussy and complain that it is outdated when run.

Version-Release number of selected component (if applicable):
wireless-tools-28-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. upgrade to latest fc6 kernel: 2.6.22.1-32
2. iwlist --version
  
Actual results:
[root@localhost ~]# iwlist --version
iwlist    Wireless-Tools version 28
          Compatible with Wireless Extension v11 to v20.

Kernel    Currently compiled with Wireless Extension v22.

eth1      Recommend Wireless Extension v16 or later,
          Currently compiled with Wireless Extension v22.

[root@localhost ~]#

Expected results:
wireless-tools supports the current wireless extensions in the kernel

Additional info:
Would it be worth rebuilding the v29 build for f8t1 on fc6  to see if it functions?

http://koji.fedoraproject.org/koji/buildinfo?buildID=7061

Comment 1 Joachim Frieben 2007-08-20 12:28:29 UTC
Not unless you are willing to rebuild 'rhpl' and 'NetworkManager', too:

  libiw.so.28 is needed by (installed) rhpl-0.194-1.i386
  libiw.so.28 is needed by (installed) NetworkManager-0.6.4-5.fc6.i386

Comment 2 Christopher Aillon 2007-09-11 18:08:37 UTC
Does this affect behaviour, or is this just cosmetic?  In FC7 we disabled this
warning from being output to the console.  I'm guessing we can do the same here.

Comment 3 nathan r. hruby 2007-09-11 20:22:54 UTC
Cosmetic, as far as I can tell.  

This laptop has a ipw3945 card in it, so I'm using freshrpms' driver and kernel
module for it.  As a side effect, WPA was busted by the combo of latest
ipw3945+fc6's wpa_supplicant.  This buglet was enough to finally motivate me to
rebuild wpa-supplicant and wireless-tools from f8t1 to fix the cosmetic issue as
well as the WPA issue I was having.

To address the issue in Comment #1 - symlinking libiw.so.28 to point at the
library provided by a newer wireless-tools packge solves the problem and
WORKSFORME. 

Comment 4 Christopher Aillon 2007-12-27 23:41:48 UTC
Since we discontinued support for Fc6, I guess I'm going to close this.  It
wasn't that big of an issue anyway, and you had a workaround.  Should not be an
issue in newer Fedora versions.


Note You need to log in before you can comment on or make changes to this bug.