Bug 251810 - xfdesktop dies on resume
xfdesktop dies on resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-11 12:11 EDT by Clark Williams
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 12:09:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2007-08-11 12:11:13 EDT
Description of problem:
xfdesktop process disappears after a resume from a suspend

Version-Release number of selected component (if applicable):
$ rpm -q xfdesktop
xfdesktop-4.4.1-2.fc8


How reproducible:
always after a resume

Steps to Reproduce:
1. start xfce (I use startx script)
2. suspend to ram
3. resume
4. xfdesktop is gone
  
Actual results:
xfesktop process not running. restarting with proper arguments allows continued
running

Expected results:
xfdesktop should survive the resume (it has in the past)


Additional info:
This is a Lenovo T60 Core2 Duo with 2GB ram. 

I have not trapped the failure yet, but plan on running xfdesktop in the
foreground from a terminal window (or possibly inside gdb).
Comment 1 Clark Williams 2007-08-11 16:46:52 EDT
after a resume, I restarted xfdesktop in gdb and got the following results after
another resume:

$ gdb /usr/bin/xfdesktop 
GNU gdb Red Hat Linux (6.6-24.fc8rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb) r --display :0.0 --sm-client-id 117f000001000117952323000000031500000
Starting program: /usr/bin/xfdesktop --display :0.0 --sm-client-id
117f000001000117952323000000031500000
(no debugging symbols found)
warning: no loadable sections found in added symbol-file system-supplied DSO at
0x7fff84ffd000
(no debugging symbols found)
   <snipped a bunch of these warnings>
Program received signal SIGSEGV, Segmentation fault.
0x00002adb26bd0759 in libhal_free_property_set () from /usr/lib64/libhal.so.1
(gdb) bt
#0  0x00002adb26bd0759 in libhal_free_property_set () from /usr/lib64/libhal.so.1
#1  0x00002adb269c49ac in libhal_volume_from_udi () from
/usr/lib64/libhal-storage.so.1
#2  0x00000030b840d5ef in thunar_vfs_info_unref () from
/usr/lib64/libthunar-vfs-1.so.2
#3  0x00002adb26bd4469 in thunar_vfs_info_unref () from /usr/lib64/libhal.so.1
#4  0x0000003e6a80e2d0 in dbus_connection_dispatch () from /lib64/libdbus-1.so.3
#5  0x0000003e6c809505 in thunar_vfs_info_unref () from
/usr/lib64/libdbus-glib-1.so.2
#6  0x0000003e62e2ef13 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#7  0x0000003e62e3220d in thunar_vfs_info_unref () from /lib64/libglib-2.0.so.0
#8  0x0000003e62e3251a in g_main_loop_run () from /lib64/libglib-2.0.so.0
#9  0x00000030b735ad43 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#10 0x0000000000410a0c in main ()


So, it looks like the SIGSEGV is in libhal. Not sure if it's a bug there or usage.
Comment 2 Kevin Fenzi 2007-08-11 18:12:27 EDT
Can you pinpoint a time when this might have started happening?

Perhaps we could determine if there was a hal update in that same timeframe? 

Do you think this is a Thunar-vfs issue? Or hal? 
Comment 3 Clark Williams 2007-08-13 13:13:22 EDT
pinpoint, probably not, but we can get close. It's been happening for over a
week on my laptop. I track rawhide pretty closely. 

Since the backtrace had libhal at the top of the stack, that would be my first
suspicion, but I'm not really familiar with all the ins-and-outs here (just a
kernel guy).  So as to whether its Thunar or libhal, I'm pretty clueless.

Clark
Comment 4 Kevin Fenzi 2007-08-13 13:36:39 EDT
Adding davidz here to CC (maintainer of hal). 

David: Any ideas on this one? 
Comment 5 Clark Williams 2007-08-21 13:24:54 EDT
Since last week, the problem has happened more frequently. I see it whenever I
connect a USB disk to the system, so I'm beginning to suspect thunar as opposed
to xfdesktop. 
Comment 6 Kevin Fenzi 2007-08-21 13:49:42 EDT
Two further questions: 

- Do you have 'thunar-volman' installed? 

- Are you running with selinux enabled? Any avcs in your /var/log/audit/audit.log? 
Comment 7 Clark Williams 2007-08-21 18:10:54 EDT
> - Do you have 'thunar-volman' installed? 

Argh, not I did not. Installed now and will try with a USB drive shortly.

> - Are you running with selinux enabled? Any avcs in your
>  /var/log/audit/audit.log? 

No. I turned it off a few weeks ago and hadn't bothered to turn it back on.
Comment 8 Clark Williams 2007-09-11 10:39:17 EDT
Huge updated in rawhide yesterday. I picked up a number of packages that might
be suspect in this bug, chief of which was hal/hal-libs. Now xfdesktop/Thunar do
not crash on resume.

I'll let this go a few days to see if anything pops up, but I suspect that we
had a problem with hal which is now resolved.
Comment 9 Clark Williams 2007-09-24 12:09:46 EDT
Works for me

Note You need to log in before you can comment on or make changes to this bug.