Bug 251811 - missing dependencies in grub RPM
Summary: missing dependencies in grub RPM
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grub   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-11 17:02 UTC by Jon Stanley
Modified: 2011-07-27 18:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-27 18:03:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Stanley 2007-08-11 17:02:50 UTC
I was experimenting with a %packages --nobase install (which basically installs
the absolute minimum required for the system to boot).  The resulting system is
unbootable since grub is not installed in the MBR.  The reason for this is the
grub-install script fails, due to it requiring at least cp and rm from coreutils
(or busybox if you want to go that far).  There should be a Requires: in the
spec file for /bin/cp and /bin/rm (and whatever else it requires, that was just
from a cursory glance at the script).


Note You need to log in before you can comment on or make changes to this bug.