Bug 251835 - Web Java applet doesn't run on MGA G550 controller
Summary: Web Java applet doesn't run on MGA G550 controller
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: http://ajaviide.delfi.ee/games/?genre...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-12 07:58 UTC by Fred New
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 05:45:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of Firefox going to this URL. (91.15 KB, application/octet-stream)
2007-08-12 07:58 UTC, Fred New
no flags Details
xorg.conf for this system (565 bytes, application/octet-stream)
2007-08-12 07:59 UTC, Fred New
no flags Details

Description Fred New 2007-08-12 07:58:02 UTC
Description of problem:
I am unable to run the Java application at
     http://ajaviide.delfi.ee/games/?genre=puzzle&game=colorblind
on my system with a G550 video adapter.  This applet runs on other F7
systems.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.6.1-3.fc7
firefox-2.0.0.5-1.fc7
jdk1.6.0_02 (non-RPM version, installed in /opt)

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox
2. Go the the URL
     http://ajaviide.delfi.ee/games/?genre=puzzle&game=colorblind
  
Actual results:
I see "Done" in the lower left corner of the Firefox window but there is no
Start button in the playing area.

Expected results:
On other systems I see "Applet Vacation started" in the lower left corner of the
Firefox window and there is also a Start button in the playing area.

Additional info:
SELinux isn't a factor.  This applet runs on other systems in enforcing mode.

Comment 1 Fred New 2007-08-12 07:58:02 UTC
Created attachment 161132 [details]
Strace of Firefox going to this URL.

Comment 2 Fred New 2007-08-12 07:59:53 UTC
Created attachment 161134 [details]
xorg.conf for this system

Comment 3 Fred New 2007-08-13 07:55:37 UTC
I am just guessing that xorg-x11-drv-mga is causing this problem.  It may be
better to assign this to the Firefox maintainers.

Comment 4 Fred New 2007-08-16 05:45:39 UTC
I just discovered that one of my working systems is running with a G550 graphics
card.  I am closing this until I can figure out a better way to make the problem
appear.

Comment 5 Fred New 2007-08-17 05:31:22 UTC
This was actually caused by a user error - I didn't have compat-libstdc++-33
installed.  This problem probably wouldn't have happened if I had installed an
RPM form of Java.


Note You need to log in before you can comment on or make changes to this bug.