Bug 251842 - Dependency not installed
Dependency not installed
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: torcs (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-12 06:21 EDT by Andrea Bruna
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-12 10:52:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Bruna 2007-08-12 06:21:41 EDT
Description of problem:
Torcs requires plib but the rpm package miss this dependency.
The problem is very simple to be resolved (a simple "yum install plib" is more
than enough) but still annoying... 

Version-Release number of selected component (if applicable):
torcs.x86_64 1.3.0-1.fc7
plib.x86_64  1.8.4-8.fc6


How reproducible:
Install torcs on a fresh system and launch the game.

Steps to Reproduce:
1. Install torcs with yum
2. Launch torcs
3.
  
Actual results:
/usr/lib64/torcs/torcs-bin: error while loading shared libraries:
libplibul.so.1.8.4: cannot open shared object file: No such file or directory


Expected results:
Torcs runs and open its game window.

Additional info:
Comment 1 Matthias Saou 2007-08-12 10:52:57 EDT
There is no problem with the torcs package :
$ rpm -q --requires torcs
[...]
libopenal.so.0  
libplibsg.so.1.8.4  
libplibsl.so.1.8.4  
libplibsm.so.1.8.4  
libplibssg.so.1.8.4  
libplibssgaux.so.1.8.4  
libplibul.so.1.8.4  
[...]
torcs-data  
torcs-data-cars-extra  
torcs-data-tracks-road

So I'm pretty sure you hit that ugly problem where some dependencies don't get
installed properly. See bug #242368 for the details.

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.