Bug 251863 - system doesnt reboot. NFS errors
Summary: system doesnt reboot. NFS errors
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-12 21:31 UTC by Robert Macaulay
Modified: 2014-03-17 03:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 01:35:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Macaulay 2007-08-12 21:31:18 UTC
Description of problem:
the halt script calls out to kexec prior to calling. This seemingly causes
access to the root NFS to timeout. When the script runs in debug mode, I get the
timeout when this command is run. Line 220 in /etc/init.d/halt
[ -f /poweroff -o ! -f /halt ] 
followed eventually by NFS timeouts.

The remote client is still pingable. The network isn't gone. If I comment out
the  line right above,
[ -n "$kexec_command" ] && $kexec_command -e >& /dev/null
the reboot works perfectly.




Version-Release number of selected component (if applicable):
system-config-netboot-0.1.41-1.FC6.noarch

How reproducible:
always

Comment 1 Robert Macaulay 2007-08-14 04:16:16 UTC
Tracked this down to the specifics on the kexec call. 
Initscripts version  initscripts-8.45.7-1

The call to the kexec command at the end of the halt /etc/init.d/halt script
should be changed from

[ -n "$kexec_command" ] && $kexec_command -e >& /dev/null

to 

[ -n "$kexec_command" ] && $kexec_command -e -x >& /dev/null

This leaves up the network interfaces which is important on a NFS mounted root.

Comment 2 Robert Macaulay 2007-08-15 01:35:54 UTC
This seems to be a dupe of #223932 on Enterprise Linux. Any chance at a backport
of it to FC6 as errata? It's for a netboot FC6 system which is ill behaved on F7
still.

Comment 3 Bill Nottingham 2007-08-29 17:20:53 UTC
Maybe, will have to see what else is pending.


Note You need to log in before you can comment on or make changes to this bug.