Bug 251878 - SCIM cannot leave message with gnome-screensaver
Summary: SCIM cannot leave message with gnome-screensaver
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-13 04:32 UTC by han pingtian
Modified: 2008-07-08 06:28 UTC (History)
6 users (show)

Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 06:28:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from Wu Peng. (3.13 KB, patch)
2008-02-29 05:05 UTC, Hu Zheng
no flags Details | Diff
Patch for scim-bridge (1.80 KB, text/x-patch)
2008-02-29 08:35 UTC, Peng Wu
no flags Details
Patch for scim (1.72 KB, patch)
2008-02-29 08:36 UTC, Peng Wu
no flags Details | Diff

Description han pingtian 2007-08-13 04:32:12 UTC
Description of problem:
I think there will be a lot of users want to be able to input utf-8 fonts into
the "leave messages" when x-window is locked. 
Thanks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2007-08-14 15:17:40 UTC
So what happens right now? If you try to activate SCIM it doesn't work?

Comment 2 Ray Strode [halfline] 2007-08-14 15:46:16 UTC
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Comment 3 han pingtian 2007-08-15 04:39:39 UTC
hi,

The SCIM cannot be actived after the screen being locked. So if trying to input
some "leave messages", you only can input english I think. 

But it's just a "be blessed with a double portion of good fortune" I think. So, if  
this can be implemented, it will be good. If cannot, it's not bad.

Comment 4 Ricky Ng-Adam 2008-01-02 20:40:37 UTC
Still a problem for gnome-screensaver-2.20.0-10.fc8: only English input is
available. 

Comment 5 Matthias Clasen 2008-02-27 22:24:03 UTC
Not an easy fix, I fear. Most likely the problem is that scim's window doesn't
get raised over the screensaver window. Fixing this may need changes to the
screensaver extension.

Comment 6 Jens Petersen 2008-02-28 01:26:48 UTC
Hmm I tested with uim and that works fine.
So looks like this is a scim issue.

Comment 7 Ray Strode [halfline] 2008-02-28 04:05:40 UTC
note we don't use the screensaver extension...

Comment 8 Peng Huang 2008-02-28 04:17:39 UTC
It seems that gtk_im_context doesn't receive key events from the GtkTextView. I
don't know what's the different between screensaver and normal gtk applications.

Comment 9 Hu Zheng 2008-02-29 05:05:06 UTC
Created attachment 296304 [details]
Patch from Wu Peng.

hi, here is a patch from Wu Peng. phuang, can you help me to verify and test
it? Thanks.

Comment 10 Peng Wu 2008-02-29 05:32:17 UTC
Please set environment variable:
export GTK_IM_MODULE=xim

Comment 11 Peng Huang 2008-02-29 06:06:29 UTC
I just tested the patch with scim-bridge & scim im module. It can not fix this
problem.
I checked the code of im-scim im module. It seems that gnome-screensaver does
not set right focused widget to im context.

Comment 12 Peng Wu 2008-02-29 08:35:50 UTC
Created attachment 296315 [details]
Patch for scim-bridge

Comment 13 Peng Wu 2008-02-29 08:36:58 UTC
Created attachment 296317 [details]
Patch for scim

Comment 14 Hu Zheng 2008-02-29 08:41:45 UTC
Nice. Can phuang check it again?

Comment 15 Peng Huang 2008-03-04 05:17:34 UTC
I tested the patches. scim can work now. 
Thanks Wu Peng.

scim was fixed in version 1.4.7-15.
Also fixed scim-bridge in version 0.4.15-1.


Comment 16 Bug Zapper 2008-05-14 03:07:19 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.