Bug 251897 - LiveCD Install to Hard Drive cannot load TimezoneWindow
LiveCD Install to Hard Drive cannot load TimezoneWindow
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 07:12 EDT by xunilarodef
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 14:00:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SQUASHFS errors found via /var/log/messages (4.22 KB, text/plain)
2007-08-19 22:40 EDT, xunilarodef
no flags Details

  None (edit)
Description xunilarodef 2007-08-13 07:12:29 EDT
Description of problem:
The installation program traps itself in an interactive
loop before collecting all information, and never actually
starts (much less finishes) installing the system onto the 
hard drive.

Version-Release number of selected component (if applicable):
anaconda from squashfs.img on Fedora-8-Test-1-Live-i686.iso
  [no /var/log/rpmpkgs on running LiveCD system, 
   so how should one extract version info for this package?]

How reproducible:
  Solidly.  Has failed every time in several attempts.

Steps to Reproduce:
1. Download Fedora-8-Test-1-Live-i686.iso
2  # sha1sum -c SHA1SUM
     Fedora-8-Test-1-Live-i686.iso: OK.
3. Boot a system from the Fedora-8-Test-1-Live-i686.iso, select
   "Verify and run from image", media check PASS, 
4. Select "Install to Hard Drive" iocn on desktop.
5. Make choices and select Next on each screen, but no further progress
   can be made after Network device screen.
  
Actual results:
A dialog titled "Error!" is displayed containing:
    [! icon] An error occurred when attempting to
    load an installer interface component.
    className = TimezoneWindow
    Exit  Retry
Selecting "Retry" just leads to a repetition (even with many attempts)
of the same dialog, with no progress, Selecting "Exit" leads to a
dialog titled "Exiting" containing:
    [! icon] Your system will now be rebooted.
    Reboot
But no restart actually happens (and not clear that one should happen).

Expected results:
The timezone installation dialog and the remainder of the
installer should be displayed, so that the installation completes.

Additional info:
When a Nautilus terminal window (from Applicatgions, System Tools, Terminal)
is open, the following lines will be displayed in it:

Loading /lib/kdb/keymaps/i386/qwerty/us.map.gz
No module named zonetab       [this line repeated for each Retry attempt ...]

The terminal lurking behind Ctrl+Alt+F3 shows:
  :
INFO    : moving (1) to step autopartitionexecute
INFO    : Detected 512M of memory
INFO    : Swap attempt of 512M to 1024M
INFO    : moving (1) to step partition
WARNING : /usr/lib/anaconda/gui.py:1158: Warning:
IA__g_object_remove_toggle_ref: couldn't find toggle ref 0x73ecfc0(0x964798c)
  self.currentWindow = None
INFO    : moving (1) to step partitiondone
INFO    : moving (1) to step bootloadersetup
INFO    : moving (1) to step bootloader
INFO    : moving (1) to step networkdevicecheck
INFO    : moving (1) to step network
INFO    : moving (1) to step timezone
Comment 1 Chris Lumens 2007-08-13 09:52:31 EDT
Are there any error messages on tty4?  This sounds like bad media, kernel driver
troubles, etc.
Comment 2 xunilarodef 2007-08-19 22:40:04 EDT
Created attachment 161837 [details]
SQUASHFS errors found via /var/log/messages

  Once I finally invested the time to attempt to repeat the situation,
after several tries I was able to verify my memory that tty4 was still
at its login prompt, with no information logged from this "Install to
Hard Drive" attempt.  As originally reported, this CD passed both the
sha1sum and media check tests.	But this time I noticed that
/var/log/messages has some evidence to support your expectation.  See
the attached file for aquashfs errors from the CD, which are obviously
intermittent since this process sometimes runs to completion without
encountering these errors from this CD on the given CD drive.

  Would it be appropriate to share your insights in a more
detailed error message available in this situation?  E.g.
a dialog titled "Error!" would be displayed containing:
    [! icon] An error occurred when attempting to
    load an installer interface component.
    className = TimezoneWindow
    [twisty] Details
      This likely arises from a media or device error:
      Consider:
      - Exiting and running the media check test, if this
	particular disc has not already passed that test.
      - Viewing the recent contents of /var/log/messages to 
	see if the device reading this disc encountered errors. 
	If so, Exit, and restart this procedure in case this
	may have been a transient error.
    Exit  Retry
Include mention of tty4 if you know that sometimes it reveals useful
messages in this situation.  Is there a simple way to distinguish
between different data being returned from the same pits in the
optical media on different runs, and squashfs driver failures?

Note You need to log in before you can comment on or make changes to this bug.